summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeoff Clements <geoff@electron.me.uk>2006-07-27 21:13:56 +0000
committerGeoff Clements <geoff@electron.me.uk>2006-07-27 21:13:56 +0000
commit5dcaf05184fa9f4fae26afb5166a8943ca70d507 (patch)
tree695b4bc57d18dae4ff859e279975109eff47cc51 /app-portage/postsync/postsync-0.1_alpha.ebuild
parentnet-misc/blocksshd: add digest (diff)
downloadsunrise-5dcaf05184fa9f4fae26afb5166a8943ca70d507.tar.gz
sunrise-5dcaf05184fa9f4fae26afb5166a8943ca70d507.tar.bz2
sunrise-5dcaf05184fa9f4fae26afb5166a8943ca70d507.zip
Initial import.
svn path=/sunrise/; revision=716
Diffstat (limited to 'app-portage/postsync/postsync-0.1_alpha.ebuild')
-rw-r--r--app-portage/postsync/postsync-0.1_alpha.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-portage/postsync/postsync-0.1_alpha.ebuild b/app-portage/postsync/postsync-0.1_alpha.ebuild
new file mode 100644
index 000000000..0664f6f91
--- /dev/null
+++ b/app-portage/postsync/postsync-0.1_alpha.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Package for controlling post emerge --sync operations"
+HOMEPAGE="http://www.electron.me.uk/postsync"
+SRC_URI="http://www.electron.me.uk/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+DEPEND=">=virtual/python-2.3"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+ PORTCFG=$(python -c 'import portage; print portage.USER_CONFIG_PATH,') \
+ || die "Cannot get config path"
+ exeinto /usr/sbin
+ doexe postsync
+
+ insinto ${PORTCFG}/bin
+ doins bin/post_sync
+ dosed "s:/etc/portage:${PORTCFG}:g" ${PORTCFG}/bin/post_sync
+
+ insinto /usr/lib/postsync.d
+ doins postsync.d/*
+
+ fowners root:portage /usr/sbin/postsync ${PORTCFG}/bin/post_sync \
+ /usr/lib/postsync.d/*
+
+ dodoc README ChangeLog doc/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Postsync programs and the postsync system are disabled by default."
+ einfo "Use postsync -l to see what programs are available then"
+ einfo "postsync -e -a <prog> [prog ...] to activate the ones you want."
+ einfo
+}
+
+pkg_prerm() {
+ /usr/sbin/postsync -d
+}