summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-04-25 15:55:10 +0000
committerAli Polatel <hawking@gentoo.org>2007-04-25 15:55:10 +0000
commitbc3d8259dc7a43ff693b77cdc6b0567d7fb8c48b (patch)
tree138e28fcaac1014288d3a78a66e40b7b99ef2705 /app-text/ps2eps/ps2eps-1.64.ebuild
parentdev-util/debug: adjusted DESCRIPTION (diff)
downloadsunrise-bc3d8259dc7a43ff693b77cdc6b0567d7fb8c48b.tar.gz
sunrise-bc3d8259dc7a43ff693b77cdc6b0567d7fb8c48b.tar.bz2
sunrise-bc3d8259dc7a43ff693b77cdc6b0567d7fb8c48b.zip
app-text/ps2eps: version bump
svn path=/sunrise/; revision=3527
Diffstat (limited to 'app-text/ps2eps/ps2eps-1.64.ebuild')
-rw-r--r--app-text/ps2eps/ps2eps-1.64.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/ps2eps/ps2eps-1.64.ebuild b/app-text/ps2eps/ps2eps-1.64.ebuild
new file mode 100644
index 000000000..0e598b5a7
--- /dev/null
+++ b/app-text/ps2eps/ps2eps-1.64.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for generating Encapsulated Postscript Format (EPS,EPSF) files from one-page Postscript documents"
+HOMEPAGE="http://www.tm.uka.de/~bless/ps2eps"
+SRC_URI="http://www.tm.uka.de/~bless/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ virtual/ghostscript"
+
+S=${WORKDIR}/${PN}
+
+src_compile(){
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} src/C/bbox.c -o bbox || die "compile failed"
+}
+
+src_install() {
+ dobin bbox bin/ps2eps
+ doman doc/man/man1/{bbox.1,ps2eps.1}
+ dodoc Changes.txt README.txt
+}