summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2009-07-30 20:31:29 +0000
committerMichał Górny <mgorny@gentoo.org>2009-07-30 20:31:29 +0000
commitf8ab43f504fd7d49945f352dca33d511e3ef5133 (patch)
treef06fcded9cb58135fdccc0d4701036ebbdc5b6be /app-text
parentapp-laptop/acerhdf: version bump (diff)
downloadsunrise-f8ab43f504fd7d49945f352dca33d511e3ef5133.tar.gz
sunrise-f8ab43f504fd7d49945f352dca33d511e3ef5133.tar.bz2
sunrise-f8ab43f504fd7d49945f352dca33d511e3ef5133.zip
app-text/tesseract-pl: Live ebuild for bug #279669 (upstream doesn't provide releases nor snapshots).
svn path=/sunrise/; revision=8896
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tesseract-pl/ChangeLog8
-rw-r--r--app-text/tesseract-pl/Manifest3
-rw-r--r--app-text/tesseract-pl/metadata.xml5
-rw-r--r--app-text/tesseract-pl/tesseract-pl-9999.ebuild44
4 files changed, 60 insertions, 0 deletions
diff --git a/app-text/tesseract-pl/ChangeLog b/app-text/tesseract-pl/ChangeLog
new file mode 100644
index 000000000..b43922c13
--- /dev/null
+++ b/app-text/tesseract-pl/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-text/tesseract-pl
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 30 Jul 2009; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ +tesseract-pl-9999.ebuild, +metadata.xml:
+ Live ebuild for bug #279669 (upstream doesn't provide releases nor snapshots).
+
diff --git a/app-text/tesseract-pl/Manifest b/app-text/tesseract-pl/Manifest
new file mode 100644
index 000000000..3b478a42d
--- /dev/null
+++ b/app-text/tesseract-pl/Manifest
@@ -0,0 +1,3 @@
+EBUILD tesseract-pl-9999.ebuild 1340 RMD160 ee7f9da5b3303f2a4d35682dbaa99a76e8df11a2 SHA1 6c00e8cae18cf21a4f04019de7284c2f799f484c SHA256 5e152939577e88011555d16a29640a2f9d6cf62b825494ea3c6048feff231c9e
+MISC ChangeLog 312 RMD160 3607dad3b8f22d9a51e98358acfc1ab3e36973ce SHA1 d1924d5f76c5428ed39fc6a79dc5c6be505cee9f SHA256 ba86d433b4a4939aa3c1b2db6da9895919fe3146962566861473d7349d51ea49
+MISC metadata.xml 171 RMD160 ed284df01c230fc7990a6b5888b39166d23f29ba SHA1 f3d64a69044b710e23fb874b3ee4cd338858c8b4 SHA256 a7b30fbacd0e4c312c07a3efac112a3794c81d134442d8104325734d03425adf
diff --git a/app-text/tesseract-pl/metadata.xml b/app-text/tesseract-pl/metadata.xml
new file mode 100644
index 000000000..6f1d493c5
--- /dev/null
+++ b/app-text/tesseract-pl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/app-text/tesseract-pl/tesseract-pl-9999.ebuild b/app-text/tesseract-pl/tesseract-pl-9999.ebuild
new file mode 100644
index 000000000..8864b70cc
--- /dev/null
+++ b/app-text/tesseract-pl/tesseract-pl-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+ESVN_REPO_URI="http://tesseract-polish.googlecode.com/svn/trunk/tessdata/"
+
+inherit subversion
+
+DESCRIPTION="Polish data files for tesseract OCR"
+HOMEPAGE="http://code.google.com/p/tesseract-polish/"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ # First we get 'tessdata' subdir with ESVN_REPO_URI specified above.
+ subversion_src_unpack
+
+ # Then we get few remaining needed files from the SVN root (--depth=files
+ # makes SVN not descend into subdirectories), making sure we get them from
+ # the same revision.
+ ESVN_REPO_URI=http://tesseract-polish.googlecode.com/svn/trunk/@${ESVN_WC_REVISION} \
+ ESVN_OPTIONS='--depth=files' subversion_src_unpack
+
+ # Some more explanation:
+ # We don't want to get the whole repo, because 'src' subdir is four times
+ # larger than everything else and we certainly won't use it.
+
+ # One more note: I don't think we need to override src_prepare() (we don't
+ # bootstrap here) nor pkg_preinst() (both checkouts use same rev).
+}
+
+src_install() {
+ # Both checkouts put the files into the same directory, that's OK.
+
+ insinto /usr/share/tessdata
+ doins pol.* || die "doins failed"
+
+ dodoc ATTRIBUTIONS BUGS NOTICE README || die "dodoc failed"
+}