summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Broadhead (hangfire) <jamesbroadhead@gmail.com>2011-11-18 21:05:16 +0000
committerJames Broadhead (hangfire) <jamesbroadhead@gmail.com>2011-11-18 21:05:16 +0000
commit0f808ad81da2d7a139c609303046ad9998e61929 (patch)
treeec8eff8e0df34a2d271e05a738325ac541dd745c /dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild
parentx11-misc/trayfreq: trayfreq ebuild: #388643; thanks to all reviewers (diff)
downloadsunrise-0f808ad81da2d7a139c609303046ad9998e61929.tar.gz
sunrise-0f808ad81da2d7a139c609303046ad9998e61929.tar.bz2
sunrise-0f808ad81da2d7a139c609303046ad9998e61929.zip
dev-embedded/palm-novacom bump
svn path=/sunrise/; revision=12517
Diffstat (limited to 'dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild')
-rw-r--r--dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild b/dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild
new file mode 100644
index 000000000..409e3a083
--- /dev/null
+++ b/dev-embedded/palm-novacom/palm-novacom-1.0.80.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+SDK_V="3.0.4.669"
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="A part of the Palm Mojo SDK for communication with and rootaccess to the webOS based devices"
+HOMEPAGE="http://developer.palm.com/"
+SRC_URI="amd64? (
+ https://cdn.downloads.palm.com/sdkdownloads/${SDK_V}/sdkBinaries/${MY_P}_amd64.deb )
+ x86? (
+ http://cdn.downloads.palm.com/sdkdownloads/${SDK_V}/sdkBinaries/${MY_P}_i386.deb )"
+
+LICENSE="PalmSDK"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE=""
+# May not be necessary.
+RESTRICT="mirror"
+
+RDEPEND="virtual/libusb:0"
+
+S=${WORKDIR}
+
+QA_PRESTRIPPED="/opt/palm-novacom/novacom
+ /opt/palm-novacom/novacomd"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_install() {
+ exeinto opt/${PN}
+ doexe opt/Palm/novacom/novacom{,d} || die
+
+ dobin opt/Palm/novacom/novaterm || die
+ newbin "${FILESDIR}/${PN}-novacom.sh" novacom || die
+
+ newsbin "${FILESDIR}/${PN}-novacomd.sh" novacomd || die
+
+ newinitd "${FILESDIR}/${PN}-initd" novacom || die
+}
+
+pkg_postinst() {
+ einfo "To use, start the novacom daemon;"
+ einfo " /etc/init.d/novacom start"
+ einfo "Then attach your Palm device with Developer Mode enabled,"
+ einfo "select 'Just Charge' and run novaterm"
+}