summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlebarjack <francois.perichon@univ-lille2.fr>2008-11-05 10:16:45 +0000
committerlebarjack <francois.perichon@univ-lille2.fr>2008-11-05 10:16:45 +0000
commit30cd4f490801aa627c60b8fc935643b3e7dd6c40 (patch)
tree6bb936e718bf53cd6a157ebee31ce1cc474782ff /dev-php/awl/awl-0.33.ebuild
parentRenaming dev-php/libawl-php to dev-php/awl to reflect upstream naming scheme (diff)
downloadsunrise-30cd4f490801aa627c60b8fc935643b3e7dd6c40.tar.gz
sunrise-30cd4f490801aa627c60b8fc935643b3e7dd6c40.tar.bz2
sunrise-30cd4f490801aa627c60b8fc935643b3e7dd6c40.zip
dev-php/awl: New version. Renamed to dev-php/awl to reflect upstream naming scheme
svn path=/sunrise/; revision=7306
Diffstat (limited to 'dev-php/awl/awl-0.33.ebuild')
-rw-r--r--dev-php/awl/awl-0.33.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/awl/awl-0.33.ebuild b/dev-php/awl/awl-0.33.ebuild
new file mode 100644
index 000000000..06b5c4561
--- /dev/null
+++ b/dev-php/awl/awl-0.33.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils php-lib-r1
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/awl/awl_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="${DEPEND}"
+
+need_php5
+
+pkg_setup() {
+ require_php_with_use pcre postgres xml
+}
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini"
+ eend $? || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ local docs="debian/README.Debian debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r "docs/api/" || die "dohtml failed"
+ fi
+
+ insinto /usr/share/awl
+ doins -r dba || die "doins failed"
+
+ php-lib-r1_src_install ./inc `find ./inc -type f -print | sed -e "s|./inc||g"`
+}