summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-04-19 20:12:09 +0000
committerMike Gilbert <floppym@gentoo.org>2011-04-19 20:12:09 +0000
commit1cd79b4ea5742a2bf7cbd05430acc5a2ac9a889f (patch)
treee6ed268e0bae6dd33a0aff06fdc2c44c868cc8f8 /dev-python/iniparse/iniparse-0.4.ebuild
parentsys-fs/e4rat: Version bump to v0.2.1. Remove patches applied upstream. (diff)
downloadsunrise-1cd79b4ea5742a2bf7cbd05430acc5a2ac9a889f.tar.gz
sunrise-1cd79b4ea5742a2bf7cbd05430acc5a2ac9a889f.tar.bz2
sunrise-1cd79b4ea5742a2bf7cbd05430acc5a2ac9a889f.zip
dev-python/iniparse: Enable python 2.4 and 2.5; implement src_test
svn path=/sunrise/; revision=11899
Diffstat (limited to 'dev-python/iniparse/iniparse-0.4.ebuild')
-rw-r--r--dev-python/iniparse/iniparse-0.4.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/iniparse/iniparse-0.4.ebuild b/dev-python/iniparse/iniparse-0.4.ebuild
index 1596d3f65..4a661b456 100644
--- a/dev-python/iniparse/iniparse-0.4.ebuild
+++ b/dev-python/iniparse/iniparse-0.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -18,3 +18,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}