summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-07-19 16:59:05 +0000
committerThomas Sachau <tommy@gentoo.org>2011-07-19 16:59:05 +0000
commit69c49276f8085f7da557d2bf12a0c4a2caeedd87 (patch)
tree6cb762c6392b0a8ab6d54faa129a9fd6ecf1cc36 /dev-python/nltk-lite/nltk-lite-0.7.5.ebuild
parentdev-python/numptr: Forced move to EAPI-3 from distutils eclass (diff)
downloadsunrise-69c49276f8085f7da557d2bf12a0c4a2caeedd87.tar.gz
sunrise-69c49276f8085f7da557d2bf12a0c4a2caeedd87.tar.bz2
sunrise-69c49276f8085f7da557d2bf12a0c4a2caeedd87.zip
dev-python/nltk-lite: Forced move to EAPI-3 from distutils eclass
svn path=/sunrise/; revision=12251
Diffstat (limited to 'dev-python/nltk-lite/nltk-lite-0.7.5.ebuild')
-rw-r--r--dev-python/nltk-lite/nltk-lite-0.7.5.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-python/nltk-lite/nltk-lite-0.7.5.ebuild b/dev-python/nltk-lite/nltk-lite-0.7.5.ebuild
index 5db076289..f8cce362a 100644
--- a/dev-python/nltk-lite/nltk-lite-0.7.5.ebuild
+++ b/dev-python/nltk-lite/nltk-lite-0.7.5.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=3
+
inherit distutils
MY_PV="${PV/_beta/b}"
@@ -28,27 +30,23 @@ S="${WORKDIR}/${MY_P}"
src_install() {
if ! use minimal ; then
- ebegin "Installing corpora"
insinto /usr/share/${MY_PN}
- doins -r "${WORKDIR}/corpora"
- doenvd "${FILESDIR}/99nltk-lite"
- eend 0
+ doins -r "${WORKDIR}/corpora" || die
+ doenvd "${FILESDIR}/99nltk-lite" || die
fi
if use doc ; then
- ebegin "Installing doc"
if ! use linguas_pt_BR ; then
- rm -rf "${WORKDIR}/doc/pt-br"
+ rm -rf "${WORKDIR}/doc/pt-br" || die
fi
insinto /usr/share/${MY_PN}
- doins -r "${WORKDIR}/doc"
- eend 0
+ doins -r "${WORKDIR}/doc" || die
fi
if use examples ; then
insinto /usr/share/${MY_PN}
- doins -r "${WORKDIR}/examples"
+ doins -r "${WORKDIR}/examples" || die
fi
- dodoc README.txt
+ dodoc README.txt || die
distutils_src_install
}