summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-03-15 17:57:49 +0000
committerAli Polatel <hawking@gentoo.org>2007-03-15 17:57:49 +0000
commit76f7d5fae9947d37139eacc48175e77d2091653a (patch)
treefcb11a73e950eb7f714d61a5714f75d39a57afe7 /dev-python/pycallgraph/pycallgraph-0.3.0.ebuild
parentdev-util/ticpp: ticpp is a fork of tinyxml and not a plain wrapper that build... (diff)
downloadsunrise-76f7d5fae9947d37139eacc48175e77d2091653a.tar.gz
sunrise-76f7d5fae9947d37139eacc48175e77d2091653a.tar.bz2
sunrise-76f7d5fae9947d37139eacc48175e77d2091653a.zip
dev-python/pycallgraph: New ebuild for bug 170806, thanks to Trevor Hardcastle
svn path=/sunrise/; revision=3248
Diffstat (limited to 'dev-python/pycallgraph/pycallgraph-0.3.0.ebuild')
-rw-r--r--dev-python/pycallgraph/pycallgraph-0.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild b/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild
new file mode 100644
index 000000000..1b99847e7
--- /dev/null
+++ b/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Python library that creates call graphs for Python programs."
+HOMEPAGE="http://pycallgraph.slowchop.com/"
+SRC_URI="http://${PN}.slowchop.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}