summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-08 15:36:17 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-08 15:36:17 +0000
commit11661635f68828324c9471afb47314da4bd84f49 (patch)
treedd580df8440bc60008bc618b38bc85a826b7e271 /dev-python/pysyck/pysyck-0.61.2.ebuild
parentdev-python/pythoncad: Added PYTHON_MODNAME and NEED_PYTHON, removed unnecessa... (diff)
downloadsunrise-11661635f68828324c9471afb47314da4bd84f49.tar.gz
sunrise-11661635f68828324c9471afb47314da4bd84f49.tar.bz2
sunrise-11661635f68828324c9471afb47314da4bd84f49.zip
dev-python/pysyck: Added NEED_PYTHON and PYTHON_MODNAME. Updated src_test.
svn path=/sunrise/; revision=2965
Diffstat (limited to 'dev-python/pysyck/pysyck-0.61.2.ebuild')
-rw-r--r--dev-python/pysyck/pysyck-0.61.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pysyck/pysyck-0.61.2.ebuild b/dev-python/pysyck/pysyck-0.61.2.ebuild
index 4d1fc7d7c..4631eb92c 100644
--- a/dev-python/pysyck/pysyck-0.61.2.ebuild
+++ b/dev-python/pysyck/pysyck-0.61.2.ebuild
@@ -2,9 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+NEED_PYTHON=2.3
+
inherit distutils eutils
-MY_P=${P/pysyck/PySyck}
+MY_P=PySyck-${PV}
DESCRIPTION="PySyck is aimed to update the current Python bindings for Syck. The new bindings provide a wrapper for the Syck emitter and give access to YAML representation graphs."
HOMEPAGE="http://pyyaml.org/"
@@ -18,6 +20,8 @@ IUSE=""
DEPEND=">=dev-libs/syck-0.55"
RDEPEND="${DEPEND}"
+PYTHON_MODNAME="syck"
+
S=${WORKDIR}/${MY_P}
pkg_setup() {
@@ -28,7 +32,6 @@ pkg_setup() {
}
src_test() {
- cd "${S}/tests"
- python test_syck.py
+ PYTHONPATH=./lib/ "${python}" tests/test_syck.py
einfo "Some tests may have failed due to pending bugs in dev-libs/syck"
}