summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-02-08 21:37:20 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-02-08 21:37:20 +0000
commit48841e96ae7c2c640ac7d0d383663caba14375a1 (patch)
tree46419eba347311d5c80eb15dee99d6a6d3687a6e /dev-python/pysyck/pysyck-0.61.2.ebuild
parentapp-text/markdown: app-arch/unzip added to DEPEND (diff)
downloadsunrise-48841e96ae7c2c640ac7d0d383663caba14375a1.tar.gz
sunrise-48841e96ae7c2c640ac7d0d383663caba14375a1.tar.bz2
sunrise-48841e96ae7c2c640ac7d0d383663caba14375a1.zip
dev-python/pysyck: DESCRIPTION and other lines length fixed. eerror output and die clearer.
svn path=/sunrise/; revision=2972
Diffstat (limited to 'dev-python/pysyck/pysyck-0.61.2.ebuild')
-rw-r--r--dev-python/pysyck/pysyck-0.61.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pysyck/pysyck-0.61.2.ebuild b/dev-python/pysyck/pysyck-0.61.2.ebuild
index 4631eb92c..80db6eaf3 100644
--- a/dev-python/pysyck/pysyck-0.61.2.ebuild
+++ b/dev-python/pysyck/pysyck-0.61.2.ebuild
@@ -8,7 +8,8 @@ inherit distutils eutils
MY_P=PySyck-${PV}
-DESCRIPTION="PySyck is aimed to update the current Python bindings for Syck. The new bindings provide a wrapper for the Syck emitter and give access to YAML representation graphs."
+DESCRIPTION="new Syck bindings which provide a wrapper for the Syck emitter and
+give access to YAML representation graphs."
HOMEPAGE="http://pyyaml.org/"
SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
@@ -25,9 +26,12 @@ PYTHON_MODNAME="syck"
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if has_version ">=dev-libs/syck-0.55-r1" && built_with_use dev-libs/syck python ; then
+ if has_version ">=dev-libs/syck-0.55-r1" \
+ && built_with_use dev-libs/syck python ; then
eerror "dev-libs/syck was already compiled with python bindings."
- die "Recompile dev-libs/syck with USE=\"-python\" to prevent collisions!"
+ eerror "Recompile dev-libs/syck with USE=\"-python\""
+ eerror "to prevent collisions."
+ die "dev-libs/syck compiled with USE=\"-python\""
fi
}