summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-06-21 21:26:12 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-06-21 21:26:12 +0000
commit68d656ed0787cc7bddd0ed6f7d3fd76550026dda (patch)
treef74af1e79fe5f4924577ea0cd9e7dd741ca2a7f4 /dev-python/pysyck/pysyck-0.61.2.ebuild
parentxfce-extra/verve - sed fix (diff)
downloadsunrise-68d656ed0787cc7bddd0ed6f7d3fd76550026dda.tar.gz
sunrise-68d656ed0787cc7bddd0ed6f7d3fd76550026dda.tar.bz2
sunrise-68d656ed0787cc7bddd0ed6f7d3fd76550026dda.zip
New PySyck Ebuild for bug 104391
svn path=/sunrise/; revision=179
Diffstat (limited to 'dev-python/pysyck/pysyck-0.61.2.ebuild')
-rw-r--r--dev-python/pysyck/pysyck-0.61.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pysyck/pysyck-0.61.2.ebuild b/dev-python/pysyck/pysyck-0.61.2.ebuild
new file mode 100644
index 000000000..2aabbc333
--- /dev/null
+++ b/dev-python/pysyck/pysyck-0.61.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_P=${P/pysyck/PySyck}
+
+DESCRIPTION="PySyck is aimed to update the current Python bindings for Syck. The new bindings provide a wrapper for the Syck emitter and give access to YAML representation graphs."
+HOMEPAGE="http://pyyaml.org"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test"
+
+DEPEND=">=dev-libs/syck-0.55"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ cd "${S}/tests"
+ python test_syck.py
+ einfo "Some tests may have failed due to pending bugs in dev-libs/syck"
+}