summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2006-09-01 20:09:00 +0000
committerJakub Moc <jakub@gentoo.org>2006-09-01 20:09:00 +0000
commitc6a1c4bae0c1a1a8054f498c4e848501f9e74b57 (patch)
treeab0ff5f05bfdbe3375b713af4baed737d618afc0 /dev-python/pysyck/pysyck-0.61.2.ebuild
parentdev-cpp/libiqxmlrpc: Version bump. (diff)
downloadsunrise-c6a1c4bae0c1a1a8054f498c4e848501f9e74b57.tar.gz
sunrise-c6a1c4bae0c1a1a8054f498c4e848501f9e74b57.tar.bz2
sunrise-c6a1c4bae0c1a1a8054f498c4e848501f9e74b57.zip
dev-python/pysyck: Prevent collissions with >=dev-libs/syck-0.55-r1
svn path=/sunrise/; revision=1101
Diffstat (limited to 'dev-python/pysyck/pysyck-0.61.2.ebuild')
-rw-r--r--dev-python/pysyck/pysyck-0.61.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pysyck/pysyck-0.61.2.ebuild b/dev-python/pysyck/pysyck-0.61.2.ebuild
index a74b50d31..3a81dbe3e 100644
--- a/dev-python/pysyck/pysyck-0.61.2.ebuild
+++ b/dev-python/pysyck/pysyck-0.61.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit distutils
+inherit distutils eutils
MY_P=${P/pysyck/PySyck}
@@ -20,6 +20,13 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ if has_version ">=dev-libs/syck-0.55-r1" && built_with_use dev-libs/syck python ; then
+ eerror "dev-libs/syck was already compiled with python bindings."
+ die "Recompile dev-libs/syck with USE=\"-python\" to prevent collisions!"
+ fi
+}
+
src_test() {
cd "${S}/tests"
python test_syck.py