summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rennings (mren) <mren@mrmx.de>2007-01-14 20:40:03 +0000
committerMarkus Rennings (mren) <mren@mrmx.de>2007-01-14 20:40:03 +0000
commitc8808a7fc18dfd1b530646735ad26fae24937e65 (patch)
tree553a1a4ac1e3808f99a89b1c42f0eb07fcbca508 /dev-tex/SIstyle/SIstyle-2.3.0.ebuild
parentapp-misc/lsx: In portage Now (diff)
downloadsunrise-c8808a7fc18dfd1b530646735ad26fae24937e65.tar.gz
sunrise-c8808a7fc18dfd1b530646735ad26fae24937e65.tar.bz2
sunrise-c8808a7fc18dfd1b530646735ad26fae24937e65.zip
dev-tex/SIstyle: Initial commit.
svn path=/sunrise/; revision=2753
Diffstat (limited to 'dev-tex/SIstyle/SIstyle-2.3.0.ebuild')
-rw-r--r--dev-tex/SIstyle/SIstyle-2.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-tex/SIstyle/SIstyle-2.3.0.ebuild b/dev-tex/SIstyle/SIstyle-2.3.0.ebuild
new file mode 100644
index 000000000..7a4378757
--- /dev/null
+++ b/dev-tex/SIstyle/SIstyle-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit latex-package
+
+DESCRIPTION="Package to typeset SI units, numbers and angles."
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/SIstyle/"
+SRC_URI="http://www.rennings.net/gentoo/distfiles/${P}.zip"
+
+LICENSE="LPPL-1.3b"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+
+ unpack "${A}"
+ cd "${S}/source/latex/SIstyle/figs"
+ unpack ./graphs_scr.zip
+
+}
+
+src_install() {
+ cd "${S}/tex/latex/SIstyle"
+ latex-package_src_install
+ cd "${S}/doc/latex/SIstyle"
+ latex-package_src_install
+
+ cd "${S}/source/latex/SIstyle"
+ insinto ${TEXMF}/source/latex/SIstyle
+ doins sistyle.dtx sistyle.ins
+ doins figs/fig{1,2}.*ps
+ cd figs/graphs_scr
+ insinto ${TEXMF}/source/latex/SIstyle/graphs_src
+ doins *.mp MPfig.bat readme_figs.txt *.m
+}