summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRóbert Čerňanský (HS) <openhs@tightmail.com>2015-05-14 18:31:19 +0200
committerRóbert Čerňanský (HS) <openhs@tightmail.com>2015-05-14 18:31:19 +0200
commit85e23025b757e9d81ed7519f734c7fc6d2f693ee (patch)
tree41ccd557395da14f54c7718b6f9beef50764c6ef /games-fps/prey/prey-20090219.ebuild
parentAutomatic update to use.local.desc (diff)
downloadsunrise-85e23025b757e9d81ed7519f734c7fc6d2f693ee.tar.gz
sunrise-85e23025b757e9d81ed7519f734c7fc6d2f693ee.tar.bz2
sunrise-85e23025b757e9d81ed7519f734c7fc6d2f693ee.zip
games-fps/prey: Updated dependencies to support multilib without emul-* packages. EAPI 5.
Diffstat (limited to 'games-fps/prey/prey-20090219.ebuild')
-rw-r--r--games-fps/prey/prey-20090219.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/games-fps/prey/prey-20090219.ebuild b/games-fps/prey/prey-20090219.ebuild
index c21547d8a..fd5bf627a 100644
--- a/games-fps/prey/prey-20090219.ebuild
+++ b/games-fps/prey/prey-20090219.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
inherit eutils games
DESCRIPTION="First person shooter from 3D Realms"
@@ -13,14 +14,17 @@ LICENSE="PREY"
SLOT="0"
KEYWORDS="~amd64"
IUSE="cdinstall dedicated openal opengl"
-PROPERTIES="interactive"
# mirror restriction might be needed as well
RESTRICT="strip"
UIDEPEND="virtual/opengl
- openal? ( x86? ( media-libs/openal )
- amd64? ( app-emulation/emul-linux-x86-sdl ) )"
+ openal? (
+ || (
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ )
+ )"
DEPEND="app-arch/unzip"
RDEPEND="
opengl? ( ${UIDEPEND} )
@@ -62,7 +66,7 @@ src_install() {
data/prey-linux-x86/libNvidiaVidMemTest.so || \
die "doexe client executables"
- dosym "/usr/$(get_libdir)/libSDL-1.2.so.0" "${dir}" || \
+ dosym "/usr/$(get_libdir)/libSDL-1.2.so.0" "${dir}/libSDL-1.2.so.0" || \
die "dosym libSDL"
if use openal; then