summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Egge (unlord) <nathanegge@yahoo.com>2007-08-22 21:43:51 +0000
committerNathan Egge (unlord) <nathanegge@yahoo.com>2007-08-22 21:43:51 +0000
commita40b13d4b1df0d0eb02c1db25a9920354077a287 (patch)
treeb7a7a3cd99c2a110ccfd982eb633af621a951fb7 /games-rpg/bs1-demo/bs1-demo-1.ebuild
parentgames-fps/uhexen2-cvs: Version bump (diff)
downloadsunrise-a40b13d4b1df0d0eb02c1db25a9920354077a287.tar.gz
sunrise-a40b13d4b1df0d0eb02c1db25a9920354077a287.tar.bz2
sunrise-a40b13d4b1df0d0eb02c1db25a9920354077a287.zip
games-rpg/bs1-demo: New ebuild for bug 142564
svn path=/sunrise/; revision=4473
Diffstat (limited to 'games-rpg/bs1-demo/bs1-demo-1.ebuild')
-rw-r--r--games-rpg/bs1-demo/bs1-demo-1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-rpg/bs1-demo/bs1-demo-1.ebuild b/games-rpg/bs1-demo/bs1-demo-1.ebuild
new file mode 100644
index 000000000..d49915589
--- /dev/null
+++ b/games-rpg/bs1-demo/bs1-demo-1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="Broken Sword 1: The Shadow of the Templars (interactive demo)"
+HOMEPAGE="http://www.revolution.co.uk/_display.php?id=14"
+SRC_URI="http://gentooexperimental.org/~unlord/bs1-demo.rar
+ http://gentooexperimental.org/~unlord/bs1-demo-cutscenes.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND=">=games-engines/scummvm-0.8.2"
+DEPEND="|| (
+ app-arch/unrar
+ app-arch/rar )"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${PN}
+
+src_install() {
+ insinto "${dir}"
+ doins SWORD_INSTALL/CLUSTERS/*.{CLU,RIF} video/*.{mp2,ogg} || die "doins failed"
+ doins -r SWORD_INSTALL/{MUSIC,SPEECH} || die "doins -r failed"
+
+ games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" sword1demo"
+ doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
+ make_desktop_entry ${PN} "Broken Sword 1 (Demo)" ${PN}.png
+
+ prepgamesdirs
+}