summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Egge (unlord) <nathanegge@yahoo.com>2007-08-22 23:22:18 +0000
committerNathan Egge (unlord) <nathanegge@yahoo.com>2007-08-22 23:22:18 +0000
commitdd6095fa2c6cd8ca02839d712a1317a15de8e7c3 (patch)
tree397dbfaaa217f6692c4680661cdce373b61ec465 /games-rpg/samnmax-demo/samnmax-demo-1.ebuild
parentgames-rpg/dig-demo: New ebuild for bug 142321 (diff)
downloadsunrise-dd6095fa2c6cd8ca02839d712a1317a15de8e7c3.tar.gz
sunrise-dd6095fa2c6cd8ca02839d712a1317a15de8e7c3.tar.bz2
sunrise-dd6095fa2c6cd8ca02839d712a1317a15de8e7c3.zip
games-rpg/samnmax-demo: New ebuild for bug 142331
svn path=/sunrise/; revision=4481
Diffstat (limited to 'games-rpg/samnmax-demo/samnmax-demo-1.ebuild')
-rw-r--r--games-rpg/samnmax-demo/samnmax-demo-1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-rpg/samnmax-demo/samnmax-demo-1.ebuild b/games-rpg/samnmax-demo/samnmax-demo-1.ebuild
new file mode 100644
index 000000000..4d76cfeac
--- /dev/null
+++ b/games-rpg/samnmax-demo/samnmax-demo-1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="Sam & Max Hit the Road (interactive demo)"
+HOMEPAGE="http://www.samandmax.net/?section=hittheroad"
+SRC_URI="http://gentooexperimental.org/~unlord/${PN}.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND=">=games-engines/scummvm-0.8.2"
+DEPEND="|| (
+ app-arch/unrar
+ app-arch/rar )"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${PN}
+
+src_install() {
+ insinto "${dir}"
+ doins SNMDEMO.{SM0,SM1} MONSTER.SOU || die "doins failed"
+
+ games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" samnmax"
+ doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
+ make_desktop_entry ${PN} "Sam & Max Hit the Road (Demo)" ${PN}.png
+
+ prepgamesdirs
+}