summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov (Displacer) <disinbox@gmail.com>2007-03-10 20:44:46 +0000
committerIgor Ulyanov (Displacer) <disinbox@gmail.com>2007-03-10 20:44:46 +0000
commit8a979bfa86443678005e0d4a9de68fa0bc35a6c2 (patch)
treec01bb71f73fc05269f09353288b7e0ab232f04a4 /games-strategy/hedgewars/hedgewars-0.9.0.ebuild
parentsys-power/s2ram: Another thing broken by the retarded pciutils zlib USE flag (diff)
downloadsunrise-8a979bfa86443678005e0d4a9de68fa0bc35a6c2.tar.gz
sunrise-8a979bfa86443678005e0d4a9de68fa0bc35a6c2.tar.bz2
sunrise-8a979bfa86443678005e0d4a9de68fa0bc35a6c2.zip
games-strategy/hedgewars: New Ebuild for bug 155872 thanks to jokey and sinrise team
svn path=/sunrise/; revision=3194
Diffstat (limited to 'games-strategy/hedgewars/hedgewars-0.9.0.ebuild')
-rw-r--r--games-strategy/hedgewars/hedgewars-0.9.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-strategy/hedgewars/hedgewars-0.9.0.ebuild b/games-strategy/hedgewars/hedgewars-0.9.0.ebuild
new file mode 100644
index 000000000..88fefdc9c
--- /dev/null
+++ b/games-strategy/hedgewars/hedgewars-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit qt4 games
+
+DESCRIPTION="Free Worms-like turn based strategy game"
+SRC_URI="http://hedgewars.org/download/${PN}-src-${PV}.tar.bz2"
+
+HOMEPAGE="http://hedgewars.org/"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=dev-util/cmake-2.4.0
+ $(qt4_min_version 4.2)
+ >=dev-lang/fpc-1.9.4
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cmake -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}" \
+ -DDATA_INSTALL_DIR="${GAMES_DATADIR}" \
+ . || die "cmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}