summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov (Displacer) <disinbox@gmail.com>2007-03-15 03:12:21 +0000
committerIgor Ulyanov (Displacer) <disinbox@gmail.com>2007-03-15 03:12:21 +0000
commitd85e8ddcf93895c9b2d6ecb2f68026d86f972e86 (patch)
treeb9752c9b838971b7d26137fc3d7a38ccc2f25752 /games-strategy
parentsci-biology/glimmerhmm: new package sci-biology/glimmerhmm (bug 170964) (diff)
downloadsunrise-d85e8ddcf93895c9b2d6ecb2f68026d86f972e86.tar.gz
sunrise-d85e8ddcf93895c9b2d6ecb2f68026d86f972e86.tar.bz2
sunrise-d85e8ddcf93895c9b2d6ecb2f68026d86f972e86.zip
revision -r1 added with a patch for some fixed bugs
svn path=/sunrise/; revision=3238
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/hedgewars/hedgewars-0.9.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-strategy/hedgewars/hedgewars-0.9.0-r1.ebuild b/games-strategy/hedgewars/hedgewars-0.9.0-r1.ebuild
new file mode 100644
index 000000000..60aa79b99
--- /dev/null
+++ b/games-strategy/hedgewars/hedgewars-0.9.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit qt4 games
+
+DESCRIPTION="Free Worms-like turn based strategy game"
+HOMEPAGE="http://hedgewars.org/"
+SRC_URI="http://hedgewars.org/download/${PN}-src-${PV}.tar.bz2
+ http://hedgewars.org/download/hedgewars-0.9.0-r1.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-util/cmake-2.4.0
+ $(qt4_min_version 4.2)
+ >=dev-lang/fpc-1.9.4
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${PF}.patch"
+}
+
+src_compile() {
+ cmake -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}" \
+ -DDATA_INSTALL_DIR="${GAMES_DATADIR}" \
+ . || die "cmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}