summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Cendron <scen@gentoo.org>2007-06-07 20:06:17 +0000
committerDavide Cendron <scen@gentoo.org>2007-06-07 20:06:17 +0000
commit39f08f6ba80848891d32a9fc38e4f148eddb833a (patch)
tree2296a2d2399d293e677a1b7fccc2224107dcc084 /games-util/glvis/glvis-1.6.ebuild
parentAdd local USE flags for net-analyzer/honeytrap, Jokey, you should know better (diff)
downloadsunrise-39f08f6ba80848891d32a9fc38e4f148eddb833a.tar.gz
sunrise-39f08f6ba80848891d32a9fc38e4f148eddb833a.tar.bz2
sunrise-39f08f6ba80848891d32a9fc38e4f148eddb833a.zip
games-util/glvis: New Ebuild for bug 138405.
svn path=/sunrise/; revision=3836
Diffstat (limited to 'games-util/glvis/glvis-1.6.ebuild')
-rw-r--r--games-util/glvis/glvis-1.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-util/glvis/glvis-1.6.ebuild b/games-util/glvis/glvis-1.6.ebuild
new file mode 100644
index 000000000..1c7f4f8af
--- /dev/null
+++ b/games-util/glvis/glvis-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PV=${PV/./}
+
+DESCRIPTION="PVS (Potentially Visible Set) builder specially designed to be used with OpenGL ports of the DOOM game engine."
+HOMEPAGE="http://www.vavoom-engine.com/glvis.php"
+SRC_URI="mirror://sourceforge/vavoom/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ dodoc ${PN}.txt || die "dodoc failed"
+}