summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2008-09-13 18:23:49 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2008-09-13 18:23:49 +0000
commit67921a100366cd32ce0ce5e619ea7cb689e8ed4f (patch)
tree874146581da8f66beac0963aac9427d3f0621c1a /media-radio/ibp/ibp-0.21.ebuild
parentnet-misc/ganyremote: New Ebuild for bug #210442 (diff)
downloadsunrise-67921a100366cd32ce0ce5e619ea7cb689e8ed4f.tar.gz
sunrise-67921a100366cd32ce0ce5e619ea7cb689e8ed4f.tar.bz2
sunrise-67921a100366cd32ce0ce5e619ea7cb689e8ed4f.zip
media-radio/ibp: New ebuild for media-radio/ibp (Bug 237579).
svn path=/sunrise/; revision=7085
Diffstat (limited to 'media-radio/ibp/ibp-0.21.ebuild')
-rw-r--r--media-radio/ibp/ibp-0.21.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/ibp/ibp-0.21.ebuild b/media-radio/ibp/ibp-0.21.ebuild
new file mode 100644
index 000000000..2e7dac680
--- /dev/null
+++ b/media-radio/ibp/ibp-0.21.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}.html"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake )"
+
+src_compile() {
+ if ( use X ) ;then
+ xmkmf || die " xmkmf failed"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1
+}