summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Carr (mca) <karman05@gmail.com>2010-12-18 00:58:54 +0000
committerMatt Carr (mca) <karman05@gmail.com>2010-12-18 00:58:54 +0000
commitbce4785c2377c575b6456ac6410a67aca685c74a (patch)
treea930780aab792765bf946d4bea67d5bce418cd5e /media-sound/pithos/pithos-9999.ebuild
parentdev-util/jsmin: Fix up jsmin ebuild to comply with tommy[d]'s standards of ac... (diff)
downloadsunrise-bce4785c2377c575b6456ac6410a67aca685c74a.tar.gz
sunrise-bce4785c2377c575b6456ac6410a67aca685c74a.tar.bz2
sunrise-bce4785c2377c575b6456ac6410a67aca685c74a.zip
media-sound/pithos: Updated ebuild for pithos, better distutils compliance, thanks to mgorny and Arfrever
svn path=/sunrise/; revision=11619
Diffstat (limited to 'media-sound/pithos/pithos-9999.ebuild')
-rw-r--r--media-sound/pithos/pithos-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/media-sound/pithos/pithos-9999.ebuild b/media-sound/pithos/pithos-9999.ebuild
index 4fa2aba47..d058636bd 100644
--- a/media-sound/pithos/pithos-9999.ebuild
+++ b/media-sound/pithos/pithos-9999.ebuild
@@ -7,9 +7,9 @@ PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
inherit bzr distutils
+EBZR_REPO_URI="lp:${PN}"
DESCRIPTION="A Pandora Radio (pandora.com) player for the GNOME Desktop"
HOMEPAGE="http://kevinmehall.net/p/pithos/"
-EBZR_REPO_URI="lp:${PN}"
LICENSE="GPL-3"
SLOT="0"
@@ -32,19 +32,16 @@ RDEPEND="dev-python/pyxdg
!gnome? ( dev-libs/keybinder )"
RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
src_prepare() {
+ distutils_src_prepare
+
# bug #216009
# avoid writing to /root/.gstreamer-0.10/registry.xml
export GST_REGISTRY="${T}"/registry.xml
- python_copy_sources
}
src_install() {
- installation() {
- "$(PYTHON)" \
- setup.py \
- install --root="${D}" --no-compile --prefix="${EPREFIX}"/usr
- }
- python_execute_function -s installation
+ distutils_src_install --prefix="${EPREFIX}/usr"
}