summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Carr (mca) <karman05@gmail.com>2010-12-06 01:28:03 +0000
committerMatt Carr (mca) <karman05@gmail.com>2010-12-06 01:28:03 +0000
commite2f281f0a14c4253d4b14fdaf7f5976cc0395c84 (patch)
tree7ffb654c1a4781348121f708c8179eb17181d31b /media-sound/pithos/pithos-9999.ebuild
parentnet-im/emesene: Added elog message about EncryptMessage plugin (diff)
downloadsunrise-e2f281f0a14c4253d4b14fdaf7f5976cc0395c84.tar.gz
sunrise-e2f281f0a14c4253d4b14fdaf7f5976cc0395c84.tar.bz2
sunrise-e2f281f0a14c4253d4b14fdaf7f5976cc0395c84.zip
media-sound/pithos: New Ebuild for bug 345815 thanks to marienz, floppym, Hawk777, chithead, and Tommy[D]
svn path=/sunrise/; revision=11588
Diffstat (limited to 'media-sound/pithos/pithos-9999.ebuild')
-rw-r--r--media-sound/pithos/pithos-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/pithos/pithos-9999.ebuild b/media-sound/pithos/pithos-9999.ebuild
new file mode 100644
index 000000000..4fa2aba47
--- /dev/null
+++ b/media-sound/pithos/pithos-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+inherit bzr distutils
+
+DESCRIPTION="A Pandora Radio (pandora.com) player for the GNOME Desktop"
+HOMEPAGE="http://kevinmehall.net/p/pithos/"
+EBZR_REPO_URI="lp:${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="gnome"
+
+DEPEND="dev-python/python-distutils-extra"
+
+RDEPEND="dev-python/pyxdg
+ dev-python/pygobject
+ dev-python/notify-python
+ dev-python/pygtk
+ dev-python/gst-python
+ dev-python/dbus-python
+ media-libs/gst-plugins-good
+ media-libs/gst-plugins-bad
+ media-plugins/gst-plugins-faad
+ media-plugins/gst-plugins-soup
+ gnome? ( gnome-base/gnome-settings-daemon )
+ !gnome? ( dev-libs/keybinder )"
+
+RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+
+src_prepare() {
+ # bug #216009
+ # avoid writing to /root/.gstreamer-0.10/registry.xml
+ export GST_REGISTRY="${T}"/registry.xml
+ python_copy_sources
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" \
+ setup.py \
+ install --root="${D}" --no-compile --prefix="${EPREFIX}"/usr
+ }
+ python_execute_function -s installation
+}