summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Newberry <brnewber@gmail.com>2006-07-29 02:43:29 +0000
committerRyan Newberry <brnewber@gmail.com>2006-07-29 02:43:29 +0000
commit4f4058a072f715bf6f54a48a5dd437c3f7ab4136 (patch)
tree086a439b4b76d541cd0eb2ac75baabb890b7e5f8 /media-sound/ripoff/ripoff-0.8.ebuild
parentnet-p2p/nanodc: version bump (diff)
downloadsunrise-4f4058a072f715bf6f54a48a5dd437c3f7ab4136.tar.gz
sunrise-4f4058a072f715bf6f54a48a5dd437c3f7ab4136.tar.bz2
sunrise-4f4058a072f715bf6f54a48a5dd437c3f7ab4136.zip
media-sound/ripoff: New Ebuild for Gentoo Bugzilla 133502
svn path=/sunrise/; revision=723
Diffstat (limited to 'media-sound/ripoff/ripoff-0.8.ebuild')
-rw-r--r--media-sound/ripoff/ripoff-0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/ripoff/ripoff-0.8.ebuild b/media-sound/ripoff/ripoff-0.8.ebuild
new file mode 100644
index 000000000..a50a46419
--- /dev/null
+++ b/media-sound/ripoff/ripoff-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+DESCRIPTION="Simple GTK+ Based CD Ripper"
+HOMEPAGE="http://ripoffc.sourceforge.net"
+SRC_URI="mirror://sourceforge/ripoffc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis mp3 flac"
+RDEPEND=">=x11-libs/gtk+-2.6
+dev-libs/libcdio
+ media-libs/libcddb
+ vorbis? ( media-libs/libvorbis )
+ mp3? ( media-sound/lame )
+ flac? ( media-libs/flac )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable vorbis) \
+ $(use_enable mp3) \
+ $(use_enable flac) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}