summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Marco Randazzo (zeld) <zeld@freaknet.org>2008-09-15 10:27:04 +0000
committerGiuseppe Marco Randazzo (zeld) <zeld@freaknet.org>2008-09-15 10:27:04 +0000
commit926bd8747b8eee18e2a606132c85edf777d1ca31 (patch)
tree623606acef19e957d92d7cb31af65f53db06a6b2 /net-analyzer/ArpON/ArpON-1.72.ebuild
parentnet-misc/ganyremote: Fix whiteys (diff)
downloadsunrise-926bd8747b8eee18e2a606132c85edf777d1ca31.tar.gz
sunrise-926bd8747b8eee18e2a606132c85edf777d1ca31.tar.bz2
sunrise-926bd8747b8eee18e2a606132c85edf777d1ca31.zip
net-analyzer/ArpON: New Ebuild for bug 225125 thanks to Giuseppe Marco Randazzo
svn path=/sunrise/; revision=7096
Diffstat (limited to 'net-analyzer/ArpON/ArpON-1.72.ebuild')
-rw-r--r--net-analyzer/ArpON/ArpON-1.72.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/ArpON/ArpON-1.72.ebuild b/net-analyzer/ArpON/ArpON-1.72.ebuild
new file mode 100644
index 000000000..fa150867a
--- /dev/null
+++ b/net-analyzer/ArpON/ArpON-1.72.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler."
+
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arpon/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake gentoo || die "emake Gentoo failed"
+}
+
+src_install() {
+ dosbin arpon || die "arpon installation failed"
+ doman man8/arpon.8 || die "arpon man installation failed"
+ dodoc AUTHORS CHANGELOG TODO || die "arpon doc instalation failed"
+}