summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-06-24 15:06:20 +0000
committerJakub Moc <jakub@gentoo.org>2007-06-24 15:06:20 +0000
commitc425516165cb64a0e32b992be8686d81c4ac3124 (patch)
treeb9b243fb7d0e7781bf4b46eeb9f88fa6fc673f61 /net-analyzer/packetgarden/packetgarden-1.0.ebuild
parentMore whitespace QA (diff)
downloadsunrise-c425516165cb64a0e32b992be8686d81c4ac3124.tar.gz
sunrise-c425516165cb64a0e32b992be8686d81c4ac3124.tar.bz2
sunrise-c425516165cb64a0e32b992be8686d81c4ac3124.zip
Tweaks and cosmetics
svn path=/sunrise/; revision=4049
Diffstat (limited to 'net-analyzer/packetgarden/packetgarden-1.0.ebuild')
-rw-r--r--net-analyzer/packetgarden/packetgarden-1.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-analyzer/packetgarden/packetgarden-1.0.ebuild b/net-analyzer/packetgarden/packetgarden-1.0.ebuild
index 6f80abaa3..a29c4d565 100644
--- a/net-analyzer/packetgarden/packetgarden-1.0.ebuild
+++ b/net-analyzer/packetgarden/packetgarden-1.0.ebuild
@@ -6,8 +6,7 @@ inherit eutils python
MY_P="${P/-/_}_all"
-DESCRIPTION="captures information about how you use the internet and use it to
-grow a private world"
+DESCRIPTION="captures information about how you use the internet and use it to grow a private world"
HOMEPAGE="http://www.packetgarden.com/"
SRC_URI="http://selectparks.net/~julian/pg/dists/${MY_P}.tar.gz"
@@ -27,7 +26,7 @@ RDEPEND="dev-python/dpkt
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if !built_with_use dev-python/soya openal ; then
+ if ! built_with_use dev-python/soya openal ; then
eerror "${PN} needs dev-python/soya built with openal USE flag enabled."
die "dev-python/soya without openal"
fi
@@ -38,15 +37,15 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-launcher.patch"
epatch "${FILESDIR}/${P}-games-path.patch"
- mv stop_capture packetgarden-stop
}
src_install() {
- dobin packetgarden packetgarden-stop
+ newbin stop_capture packetgarden-stop
+ dobin packetgarden
insinto /usr/share/${PN}
doins -r config data guide labels logs stats pg_*.py
dodoc README_LINUX.txt
- dodir /usr/share/${PN}/data/images/screenshots
+ keepdir /usr/share/${PN}/data/images/screenshots
}
pkg_postinst() {