summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2009-02-10 21:32:33 +0000
committerTom Hendrikx (whyscream) <tom@whyscream.net>2009-02-10 21:32:33 +0000
commit83e161306b0c54a1cd4044163d3c1395f74c55f0 (patch)
tree01df4c5d1f94f0332914da520b98433446e6c465 /net-dns/ldns-utils/ldns-utils-1.5.1.ebuild
parentnet-libs/ldns: bugfix release, version bump (diff)
downloadsunrise-83e161306b0c54a1cd4044163d3c1395f74c55f0.tar.gz
sunrise-83e161306b0c54a1cd4044163d3c1395f74c55f0.tar.bz2
sunrise-83e161306b0c54a1cd4044163d3c1395f74c55f0.zip
net-dns/ldns-utils: bugfix release, version bump
svn path=/sunrise/; revision=7901
Diffstat (limited to 'net-dns/ldns-utils/ldns-utils-1.5.1.ebuild')
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.5.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-dns/ldns-utils/ldns-utils-1.5.1.ebuild b/net-dns/ldns-utils/ldns-utils-1.5.1.ebuild
new file mode 100644
index 000000000..e899678df
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/ldns-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=net-libs/ldns-${PV}
+ net-libs/libpcap"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/ldns-${PV}
+
+DIRS="drill examples"
+
+src_compile() {
+ for dir in ${DIRS}; do
+ einfo "Building in ${dir}"
+ cd "${dir}"
+ econf
+ emake || die "emake in ""${dir}"" failed"
+ cd ..
+ done
+}
+
+src_install() {
+ for dir in ${DIRS}; do
+ cd "${dir}"
+ emake DESTDIR="${D}" install || die "emake install in ""${dir}"" failed"
+ cd ..
+ done
+
+ dodoc Changelog README || die "Adding documentation failed"
+}