summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2008-07-16 14:43:46 +0000
committerTom Hendrikx (whyscream) <tom@whyscream.net>2008-07-16 14:43:46 +0000
commit8a1bc2fecdcc3f237a364dfa14ce8c55f7eaac87 (patch)
treef11ed23e596383d9b15cce64333da6066974be72 /net-dns/nsd/nsd-3.1.0.ebuild
parentgames-rpg/ft: New ebuild for bug 231900 (diff)
downloadsunrise-8a1bc2fecdcc3f237a364dfa14ce8c55f7eaac87.tar.gz
sunrise-8a1bc2fecdcc3f237a364dfa14ce8c55f7eaac87.tar.bz2
sunrise-8a1bc2fecdcc3f237a364dfa14ce8c55f7eaac87.zip
net-dns/nsd: Version bump with several ebuild changes, incorporating various changes from bug 128246, with thanks to dev tommy for reviewing
svn path=/sunrise/; revision=6504
Diffstat (limited to 'net-dns/nsd/nsd-3.1.0.ebuild')
-rw-r--r--net-dns/nsd/nsd-3.1.0.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-dns/nsd/nsd-3.1.0.ebuild b/net-dns/nsd/nsd-3.1.0.ebuild
new file mode 100644
index 000000000..ee48c2de7
--- /dev/null
+++ b/net-dns/nsd/nsd-3.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/nsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnssec ipv6 largefile nsec3 nsid root-server runtime-checks tsig"
+
+DEPEND="tsig? ( >=dev-libs/openssl-0.9.8f )"
+
+pkg_setup() {
+ if use runtime-checks; then
+ ewarn "You enabled runtime-checks USE flag, this could lead to a reduced service level"
+ fi
+ if use nsid; then
+ ewarn "You enabled nsid USE flag, this is still experimental"
+ fi
+
+ enewuser nsd -1 -1 /var/lib/nsd
+}
+
+src_compile() {
+ econf \
+ --with-dbfile=/var/db/nsd/nsd.db \
+ --with-difffile=/var/db/nsd/ixfr.db \
+ --with-pidfile=/var/run/nsd.pid \
+ --with-xfrdfile=/var/db/nsd/xfrd.state \
+ --with-zonesdir=/var/lib/nsd \
+ $(use_enable bind8-stats) \
+ $(use_enable dnssec) \
+ $(use_enable largefile) \
+ $(use_enable ipv6) \
+ $(use_enable nsec3) \
+ $(use_enable nsid) \
+ $(use_enable root-server) \
+ $(use_enable runtime-checks checking) \
+ $(use_enable tsig) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc doc/*
+ dodoc contrib/nsd.zones2nsd.conf
+ dodoc "${FILESDIR}"/nsd.cron
+
+ dobin nsdc.sh
+
+ newinitd "${FILESDIR}"/nsd.initd nsd
+
+ keepdir /var/db/nsd
+ fowners nsd /var/db/nsd
+ fperms 750 /var/db/nsd
+
+ keepdir /var/lib/nsd
+ fowners nsd /var/lib/nsd
+ fperms 750 /var/lib/nsd
+}
+
+pkg_postinst() {
+ elog "If you are using bind and want to convert (or sync) bind zones"
+ elog "you should check out bind2nsd (http://bind2nsd.sourceforge.net)."
+ echo
+ elog "If you are upgrading from NSD 2, take a look at the provided"
+ elog "nsd.zones2nsd.conf script in the doc directory."
+ echo
+ elog "To automatically merge zone transfer changes back to NSD's"
+ elog "zone files using 'nsdc patch', try the nsd.cron in the doc directory"
+}