summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-31 14:27:17 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-31 14:27:17 +0000
commit73970b39a356c6fe80a8c18a968353f7bf2ecefd (patch)
treed7d8d2a572b84794f7fcfaebdaa37b6fe4fec319 /net-libs
parentdev-libs/libuv: New Ebuild for bug 410337 thanks to Tommy[D] chithead and ssu... (diff)
downloadsunrise-73970b39a356c6fe80a8c18a968353f7bf2ecefd.tar.gz
sunrise-73970b39a356c6fe80a8c18a968353f7bf2ecefd.tar.bz2
sunrise-73970b39a356c6fe80a8c18a968353f7bf2ecefd.zip
net-libs/http-parser: New Ebuild for bug 410339 thanks to Tommy[D] chithead Enlik and ssuominen
svn path=/sunrise/; revision=12879
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/http-parser/ChangeLog11
-rw-r--r--net-libs/http-parser/Manifest5
-rw-r--r--net-libs/http-parser/files/20120331-makefile.patch17
-rw-r--r--net-libs/http-parser/http-parser-1.0_pre20120331.ebuild36
-rw-r--r--net-libs/http-parser/metadata.xml7
5 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
new file mode 100644
index 000000000..b3f53ca3d
--- /dev/null
+++ b/net-libs/http-parser/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-libs/http-parser
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*http-parser-1.0_pre20120331 (31 Mar 2012)
+
+ 31 Mar 2012; hasufell <julian.ospald@googlemail.com>
+ +files/20120331-makefile.patch, +http-parser-1.0_pre20120331.ebuild,
+ +metadata.xml:
+ New Ebuild for bug 410339 thanks to Tommy[D] chithead Enlik and ssuominen
+
diff --git a/net-libs/http-parser/Manifest b/net-libs/http-parser/Manifest
new file mode 100644
index 000000000..bd9e2a63f
--- /dev/null
+++ b/net-libs/http-parser/Manifest
@@ -0,0 +1,5 @@
+AUX 20120331-makefile.patch 534 RMD160 7bbb812a1207e074ea381ef7fecd393ee9893be5 SHA1 e9ad8c8ab8259a99baa741f53324c17ad570315e SHA256 a1c15c1b317eaa673b1847afa30e40dbce239a80aff63df9edb55389580c9ed2
+DIST http-parser-1.0_pre20120331.tar.gz 36251 RMD160 35de87e00ea6d09546c6a73a2f2207d6a1a3beeb SHA1 b9d1351359328be3bc80e2dc3ae0a54ece330519 SHA256 a5601109269c1540d769011d502e6e68c5c963be0265539f229c9ec2a43a73fa
+EBUILD http-parser-1.0_pre20120331.ebuild 851 RMD160 e4994317605286da5bb8bc4f6fe693239ad5b53f SHA1 a3d1a10b100384d6f20945c2d2e4741715a63747 SHA256 9028ee40b627fcd68f2cf25caa1393b3ed0f27e58fffc0bfbbfb6a437f4ceaa3
+MISC ChangeLog 385 RMD160 35e40c5025420a3346fb48c9cdb3a05464df5df0 SHA1 9e571985a3cb290acc063122b92ebff0dd496e0d SHA256 8113bfcf834d2cdd58d3f634c81d9e823f5d3ca4028cf50a7d3b51df966e207c
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/net-libs/http-parser/files/20120331-makefile.patch b/net-libs/http-parser/files/20120331-makefile.patch
new file mode 100644
index 000000000..14f948a29
--- /dev/null
+++ b/net-libs/http-parser/files/20120331-makefile.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <julian.ospald@googlemail.com>
+Date: Sat Mar 31 01:11:44 CEST 2012
+
+fix "QA Notice: The following shared libraries lack a SONAME"
+respect LDFLAGS
+
+--- Makefile
++++ Makefile
+@@ -44,7 +44,7 @@
+ $(CC) $(CPPFLAGS_FAST) $(CFLAGS_LIB) -c http_parser.c -o libhttp_parser.o
+
+ library: libhttp_parser.o
+- $(CC) -shared -o libhttp_parser.so libhttp_parser.o
++ $(CC) $(LDFLAGS) -Wl,-soname,libhttp_parser.so -shared -o libhttp_parser.so libhttp_parser.o
+
+ package: http_parser.o
+ $(AR) rcs libhttp_parser.a http_parser.o
diff --git a/net-libs/http-parser/http-parser-1.0_pre20120331.ebuild b/net-libs/http-parser/http-parser-1.0_pre20120331.ebuild
new file mode 100644
index 000000000..0dc6e1f69
--- /dev/null
+++ b/net-libs/http-parser/http-parser-1.0_pre20120331.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A parser for HTTP messages written in C. It parses both requests and responses"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/downloads/hasufell/tinkerbox/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # fix SONAME/LDFLAGS
+ epatch "${FILESDIR}"/20120331-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake library
+}
+
+src_install() {
+ insinto /usr/include/${PN}
+ doins http_parser.h
+ newlib.so libhttp_parser.so libhttp_parser.so.1.0
+ dosym libhttp_parser.so.1.0 /usr/$(get_libdir)/libhttp_parser.so.1
+ dosym libhttp_parser.so.1.0 /usr/$(get_libdir)/libhttp_parser.so
+
+ newdoc README.md README
+}
diff --git a/net-libs/http-parser/metadata.xml b/net-libs/http-parser/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/net-libs/http-parser/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>