summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Cunningham (slithy) <uber.leoj@gmail.com>2008-05-25 00:36:08 +0000
committerJoel Cunningham (slithy) <uber.leoj@gmail.com>2008-05-25 00:36:08 +0000
commite8ef26cdb3eb87827bf5723b9bd149b23500f3eb (patch)
tree205cf477f7c72f08dd50ce35a1b41f0814951d30 /net-mail/checkgmail/checkgmail-1.13.ebuild
parentnet-p2p/freenet: New upstream release + update live ebuild (diff)
downloadsunrise-e8ef26cdb3eb87827bf5723b9bd149b23500f3eb.tar.gz
sunrise-e8ef26cdb3eb87827bf5723b9bd149b23500f3eb.tar.bz2
sunrise-e8ef26cdb3eb87827bf5723b9bd149b23500f3eb.zip
net-mail/checkgmail: New Ebuild for bug 117867
svn path=/sunrise/; revision=6217
Diffstat (limited to 'net-mail/checkgmail/checkgmail-1.13.ebuild')
-rw-r--r--net-mail/checkgmail/checkgmail-1.13.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-mail/checkgmail/checkgmail-1.13.ebuild b/net-mail/checkgmail/checkgmail-1.13.ebuild
new file mode 100644
index 000000000..0c2abfab3
--- /dev/null
+++ b/net-mail/checkgmail/checkgmail-1.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="a Gmail Notifier for Linux"
+HOMEPAGE="http://checkgmail.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clickurl savepwd"
+
+DEPEND=">=dev-perl/gtk2-perl-1.100
+ >=dev-perl/gtk2-trayicon-0.03
+ >=dev-perl/libwww-perl-5.800
+ >=dev-perl/Crypt-SSLeay-0.49
+ >=dev-perl/XML-Simple-2.12
+ >=x11-libs/gtk+-2.6
+ clickurl? ( >=x11-libs/libsexy-0.1.11
+ >=dev-perl/Gtk2-Sexy-0.02 )
+ savepwd? ( >=dev-perl/Crypt-Simple-0.06 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-lang/perl ithreads ; then
+ local msg="Please (re)emerge dev-lang/perl with the ithreads USE flag on"
+ eerror "${msg}"
+ die "${msg}"
+ fi
+}
+
+src_install() {
+ dobin checkgmail || die "dobin failed"
+ dodoc ChangeLog Readme todo
+ doman man/checkgmail.1.gz
+}