summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2008-11-29 18:58:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2008-11-29 18:58:19 +0000
commit954b2bf49f60aecf5c971dfb20a81bf18c7dc235 (patch)
tree7ce20740f4490b592d98e3757fb1f62b7ccd2ec2 /net-misc/anyremote/anyremote-4.12.ebuild
parentnet-misc/netgo_ng: Version Bump (diff)
downloadsunrise-954b2bf49f60aecf5c971dfb20a81bf18c7dc235.tar.gz
sunrise-954b2bf49f60aecf5c971dfb20a81bf18c7dc235.tar.bz2
sunrise-954b2bf49f60aecf5c971dfb20a81bf18c7dc235.zip
net-misc/anyremote: version bump, removed bluetooth patch
svn path=/sunrise/; revision=7418
Diffstat (limited to 'net-misc/anyremote/anyremote-4.12.ebuild')
-rw-r--r--net-misc/anyremote/anyremote-4.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/anyremote/anyremote-4.12.ebuild b/net-misc/anyremote/anyremote-4.12.ebuild
new file mode 100644
index 000000000..11b15c200
--- /dev/null
+++ b/net-misc/anyremote/anyremote-4.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Anyremote provides wireless Bluetooth or infrared remote control service, but works also with cable"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome kde"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs net-wireless/bluez-utils )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+PDEPEND="kde? ( net-misc/kanyremote )
+ gnome? ( net-misc/ganyremote )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ econf $(use_enable bluetooth bluez)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}