summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-01-25 11:16:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-01-25 11:16:07 +0000
commit01003851e316cc0c4f42c946974c5f618acfcaad (patch)
tree29cea4a6e9a3175405f8fbd69ab319f3581e0119 /net-misc/kanyremote/kanyremote-5.6.1.ebuild
parentgames-util/playonlinux: Updated ebuild 3.2.2 -> 3.3 (diff)
downloadsunrise-01003851e316cc0c4f42c946974c5f618acfcaad.tar.gz
sunrise-01003851e316cc0c4f42c946974c5f618acfcaad.tar.bz2
sunrise-01003851e316cc0c4f42c946974c5f618acfcaad.zip
net-misc/kanyremote: version bump
svn path=/sunrise/; revision=7795
Diffstat (limited to 'net-misc/kanyremote/kanyremote-5.6.1.ebuild')
-rw-r--r--net-misc/kanyremote/kanyremote-5.6.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/kanyremote/kanyremote-5.6.1.ebuild b/net-misc/kanyremote/kanyremote-5.6.1.ebuild
new file mode 100644
index 000000000..3866497b2
--- /dev/null
+++ b/net-misc/kanyremote/kanyremote-5.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/anyremote-4.4
+ >=dev-python/PyQt-3.17
+ >=dev-python/pykde-3.16"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if ! built_with_use net-misc/anyremote bluetooth ; then
+ einfo
+ einfo "If you want to use bluetooth with kanyremote, you need to"
+ einfo "compile net-misc/anyremote with bluetooth use flag."
+ fi
+}
+