summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-23 09:08:57 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-23 09:08:57 +0000
commit75554368a80f3b8c67e9b8baf7496a8c6626124a (patch)
tree852db389ef934e51b13e50a1e32db1f22ac79ce8 /net-p2p/museek+/museek+-0.1.11.ebuild
parentapp-emulation/xenman: Added sys-fs/lvm2 with lvm2 USE-flag to RDEPEND, thanks... (diff)
downloadsunrise-75554368a80f3b8c67e9b8baf7496a8c6626124a.tar.gz
sunrise-75554368a80f3b8c67e9b8baf7496a8c6626124a.tar.bz2
sunrise-75554368a80f3b8c67e9b8baf7496a8c6626124a.zip
net-p2p/museek+: misc ebuild cleanups, please take a look
svn path=/sunrise/; revision=1310
Diffstat (limited to 'net-p2p/museek+/museek+-0.1.11.ebuild')
-rw-r--r--net-p2p/museek+/museek+-0.1.11.ebuild39
1 files changed, 12 insertions, 27 deletions
diff --git a/net-p2p/museek+/museek+-0.1.11.ebuild b/net-p2p/museek+/museek+-0.1.11.ebuild
index 2b3b0c889..9bbd95747 100644
--- a/net-p2p/museek+/museek+-0.1.11.ebuild
+++ b/net-p2p/museek+/museek+-0.1.11.ebuild
@@ -53,25 +53,12 @@ src_unpack() {
src_compile() {
local myconf=""
- if ! use qt3 ; then
- myconf="${myconf} MUSEEQ=no"
- fi
- if ! use qsa ; then
- myconf="${myconf} QSA=no"
- fi
- if ! use gtk ; then
- myconf="${myconf} MUSETUPGTK=no"
- fi
- if ! use ncurses ; then
- myconf="${myconf} MUCOUS=no"
- fi
- if ! use vorbis ; then
- myconf="${myconf} VORBIS=no"
- fi
-
- if use debug ; then
- myconf="${myconf} MULOG=cycle,debug"
- fi
+ use qt3 || myconf="${myconf} MUSEEQ=no"
+ use qsa || myconf="${myconf} QSA=no"
+ use gtk || myconf="${myconf} MUSETUPGTK=no"
+ use ncurses || myconf="${myconf} MUCOUS=no"
+ use vorbis || myconf="${myconf} VORBIS=no"
+ use debug && myconf="${myconf} MULOG=cycle,debug"
local mylinguas=""
for X in ${LANGS} ; do
@@ -82,11 +69,11 @@ src_compile() {
myconf="${myconf} MUSEEQTRANSLATIONS=${mylinguas/,$/}"
- scons ${myconf} CFLAGS="${CFLAGS}" PREFIX=/usr
+ scons ${myconf} CFLAGS="${CFLAGS}" PREFIX=/usr || die "scons failed"
}
src_install() {
- scons DESTDIR="${D}" install
+ scons DESTDIR="${D}" install || die "scons install failed"
dodoc README
if use qt3 ; then
@@ -96,13 +83,11 @@ src_install() {
fi
# conf.d and init.d scripts by SeeSchloss
- exeinto /etc/init.d
- #newexe "${FILESDIR}/conf.d-mulog" mulog
- newexe "${FILESDIR}/init.d-museekd" museekd
+ #newinitd "${FILESDIR}/init.d-mulog" mulog
+ newinitd "${FILESDIR}/init.d-museekd" museekd
- insinto /etc/conf.d
- #newins "${FILESDIR}"/conf.d-mulog mulog
- newins "${FILESDIR}/conf.d-museekd" museekd
+ #newconfd "${FILESDIR}"/conf.d-mulog mulog
+ newconfd "${FILESDIR}/conf.d-museekd" museekd
}
pkg_postinst() {