summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-01-13 14:54:16 +0000
committerJakub Moc <jakub@gentoo.org>2008-01-13 14:54:16 +0000
commit0776f9823ac0b8800db92defc497704562716a5d (patch)
tree82aea74b922a67a44d9a49ff58f305aa8dec11a1 /net-p2p/mute/mute-0.5.ebuild
parentNuke stray backslash (diff)
downloadsunrise-0776f9823ac0b8800db92defc497704562716a5d.tar.gz
sunrise-0776f9823ac0b8800db92defc497704562716a5d.tar.bz2
sunrise-0776f9823ac0b8800db92defc497704562716a5d.zip
net-p2p/mute: Fix wxGTK handling
svn path=/sunrise/; revision=5395
Diffstat (limited to 'net-p2p/mute/mute-0.5.ebuild')
-rw-r--r--net-p2p/mute/mute-0.5.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-p2p/mute/mute-0.5.ebuild b/net-p2p/mute/mute-0.5.ebuild
index cfb0b922d..c3091e798 100644
--- a/net-p2p/mute/mute-0.5.ebuild
+++ b/net-p2p/mute/mute-0.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+WX_GTK_VER="2.6"
inherit eutils toolchain-funcs wxwidgets flag-o-matic multilib
MY_P="MUTE_fileSharing-${PV}_UnixSource"
@@ -17,8 +18,8 @@ KEYWORDS="~x86"
IUSE="wxwindows"
DEPEND="dev-libs/crypto++
- wxwindows? ( >=x11-libs/wxGTK-2.6 )"
-RDEPEND=$DEPEND
+ wxwindows? ( =x11-libs/wxGTK-2.6* )"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -44,8 +45,7 @@ src_compile() {
emake GXX=$(tc-getCXX) CRYPTO_LIB="/usr/$(get_libdir)/libcrypto++.a" || die "emake failed"
if use wxwindows; then
- export WX_GTK_VER=2.6
- need-wxwidgets gtk2 || die
+ need-wxwidgets gtk2
cd "${S}/MUTE/otherApps/fileSharing/userInterface/wxWindows"
emake GXX="$(tc-getCXX)" WX_CONFIG="${WX_CONFIG}" \
CRYPTO_LIB="/usr/$(get_libdir)/libcrypto++.a" || die "emake failed"