summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-01-07 12:40:12 +0000
committerJakub Moc <jakub@gentoo.org>2007-01-07 12:40:12 +0000
commit15ea956f07c5710814bf398f37ba286ae60032f1 (patch)
treeb92c88ca3c44c74f59b007e158d6840e1a28588d /net-p2p/mute/mute-0.5.ebuild
parentx11-wm/dwm: einfo -> elog; save config in preinst instead of postinst to not... (diff)
downloadsunrise-15ea956f07c5710814bf398f37ba286ae60032f1.tar.gz
sunrise-15ea956f07c5710814bf398f37ba286ae60032f1.tar.bz2
sunrise-15ea956f07c5710814bf398f37ba286ae60032f1.zip
net-p2p/mute: Make this multilib friendly; package.masked until someone patches this for gcc-4.x
svn path=/sunrise/; revision=2669
Diffstat (limited to 'net-p2p/mute/mute-0.5.ebuild')
-rw-r--r--net-p2p/mute/mute-0.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/mute/mute-0.5.ebuild b/net-p2p/mute/mute-0.5.ebuild
index 6f46f8927..20b579b3c 100644
--- a/net-p2p/mute/mute-0.5.ebuild
+++ b/net-p2p/mute/mute-0.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils toolchain-funcs wxwidgets flag-o-matic
+inherit eutils toolchain-funcs wxwidgets flag-o-matic multilib
MY_P="MUTE_fileSharing-${PV}_UnixSource"
@@ -53,12 +53,12 @@ src_compile() {
# break the crypto at startup
filter-flags -fomit-frame-pointer
- emake GXX=$(tc-getCXX) CRYPTO_LIB="/usr/lib/libcrypto++.a" || die "emake failed"
+ emake GXX=$(tc-getCXX) CRYPTO_LIB="/usr/$(get_libdir)/libcrypto++.a" || die "emake failed"
if use wxwindows; then
cd "${S}/MUTE/otherApps/fileSharing/userInterface/wxWindows"
emake GXX="$(tc-getCXX)" WX_CONFIG="${WX_CONFIG}" \
- CRYPTO_LIB="/usr/lib/libcrypto++.a" || die "emake failed"
+ CRYPTO_LIB="/usr/$(get_libdir)/libcrypto++.a" || die "emake failed"
fi
}