summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-01-05 11:48:10 +0000
committerJakub Moc <jakub@gentoo.org>2007-01-05 11:48:10 +0000
commit64f1e538c52f66d7302b629855595916619a6a86 (patch)
tree37cf34f7f582989259fb56c030b988a1dfb0f0d4 /net-p2p/mute/mute-0.5.ebuild
parentdev-util/tla-tools: Remove broken src_unpack; this does not eautoreconf due t... (diff)
downloadsunrise-64f1e538c52f66d7302b629855595916619a6a86.tar.gz
sunrise-64f1e538c52f66d7302b629855595916619a6a86.tar.bz2
sunrise-64f1e538c52f66d7302b629855595916619a6a86.zip
net-p2p/mute: Fix broken wxwidgets handling, add die to configure call, cosmetics
svn path=/sunrise/; revision=2587
Diffstat (limited to 'net-p2p/mute/mute-0.5.ebuild')
-rw-r--r--net-p2p/mute/mute-0.5.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/net-p2p/mute/mute-0.5.ebuild b/net-p2p/mute/mute-0.5.ebuild
index 5aea46712..880c42157 100644
--- a/net-p2p/mute/mute-0.5.ebuild
+++ b/net-p2p/mute/mute-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -17,35 +17,37 @@ KEYWORDS="~x86"
IUSE="wxwindows"
DEPEND="wxwindows? ( >=x11-libs/wxGTK-2.6 )"
-RDEPEND=$DEPEND
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ if use wxwindows ; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ fi
+
+ if [ $(gcc-major-version) -ge 4 ]; then
+ einfo "${P} doesn't compile with gcc version >= 4"
+ die "${P} needs gcc version < 4"
+ fi
+}
+
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-configure.patch"
epatch "${FILESDIR}/${P}-makefile.patch"
- cd "${S}/MUTE/otherApps/fileSharing/userInterface/languages/"
+ cd "${S}"/MUTE/otherApps/fileSharing/userInterface/languages/
mv Espa?ol.txt Espanol.txt
rm TranslationHelper.txt
}
-pkg_setup() {
- if [ $(gcc-major-version) -ge 4 ]; then
- einfo "${P} doesn't compile with gcc version >= 4"
- die "${P} needs gcc version < 4"
- fi
-}
-
src_compile() {
- export WX_GTK_VER=2.6
- need-wxwidgets gtk2 || die
-
# not an autotools configure
cd "${S}/MUTE"
- ./configure >/dev/null
+ ./configure >/dev/null || die "configure failed"
# break the crypto at startup
filter-flags -fomit-frame-pointer