summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-05-14 09:27:24 +0000
committerJakub Moc <jakub@gentoo.org>2007-05-14 09:27:24 +0000
commitd86c6858bb6754bc1a85ee18979af7fd594eccc5 (patch)
tree6c2ddebf71179f35aca7c7461fc67b6c18fbf705 /net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild
parentnet-wireless/crc-itu-t: New ebuild, needed for rt2x00 git versions, thanks to... (diff)
downloadsunrise-d86c6858bb6754bc1a85ee18979af7fd594eccc5.tar.gz
sunrise-d86c6858bb6754bc1a85ee18979af7fd594eccc5.tar.bz2
sunrise-d86c6858bb6754bc1a85ee18979af7fd594eccc5.zip
net-wireless/eeprom_93cx6: New ebuild, needed for rt2x00 git versions, thanks to Dick Marinus. Bug 176148
svn path=/sunrise/; revision=3629
Diffstat (limited to 'net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild')
-rw-r--r--net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild b/net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild
new file mode 100644
index 000000000..04fabeab8
--- /dev/null
+++ b/net-wireless/eeprom_93cx6/eeprom_93cx6-20070513.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit linux-mod
+
+MY_PN="rt2x00-git"
+DESCRIPTION="EEPROM reader routines for 93cx6 chipsets."
+HOMEPAGE="http://rt2x00.serialmonkey.com/"
+SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/drivers/misc"
+
+BUILD_PARAMS="CONFIG_EEPROM_93CX6=m -C ${KV_DIR} M=${S}"
+BUILD_TARGETS="modules"
+MODULE_NAMES="eeprom_93cx6()"
+
+src_unpack() {
+ unpack ${A}
+ echo "CFLAGS += -I${WORKDIR}/include" >> ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+ dodir /usr/include/eeprom_93cx6/linux/
+ insinto /usr/include/eeprom_93cx6/linux/
+ doins "${WORKDIR}"/include/linux/eeprom_93cx6.h
+}