summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2006-09-08 23:05:54 +0000
committerDavid Shakaryan <omp@gentoo.org>2006-09-08 23:05:54 +0000
commit1cf5e084bcdc85d9ca9fa31fa4144dc648208125 (patch)
treeeff6e771d9821b7cfea03ae0797ae841a6159775 /net-wireless/rt73/rt73-1.0.3.6.ebuild
parentdev-lang/awib: New ebuild for bug 146885 (diff)
downloadsunrise-1cf5e084bcdc85d9ca9fa31fa4144dc648208125.tar.gz
sunrise-1cf5e084bcdc85d9ca9fa31fa4144dc648208125.tar.bz2
sunrise-1cf5e084bcdc85d9ca9fa31fa4144dc648208125.zip
net-wireless/rt73: many aesthetic changes
svn path=/sunrise/; revision=1196
Diffstat (limited to 'net-wireless/rt73/rt73-1.0.3.6.ebuild')
-rw-r--r--net-wireless/rt73/rt73-1.0.3.6.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/net-wireless/rt73/rt73-1.0.3.6.ebuild b/net-wireless/rt73/rt73-1.0.3.6.ebuild
index 85b71e8f1..b8a3b189c 100644
--- a/net-wireless/rt73/rt73-1.0.3.6.ebuild
+++ b/net-wireless/rt73/rt73-1.0.3.6.ebuild
@@ -6,23 +6,23 @@ inherit linux-mod
DESCRIPTION="Driver for the RaLink RT73/2571 wireless chipsets"
HOMEPAGE="http://www.ralink.com.tw"
-LICENSE="GPL-2"
-
-MY_P=RT73_Linux_STA_Drv${PV}
-
SRC_URI="http://www.ralink.com.tw/drivers/Linux/RT73_Linux_STA_Drv${PV}.tar.gz"
-# May work on other little endien arches, e.g amd64 - known broken on big endian arches
+MY_P=RT73_Linux_STA_Drv${PV}
+# May work on other little endien arches, e.g amd64
+# Known broken on big endian arches
+LICENSE="GPL-2"
KEYWORDS="~x86"
IUSE="debug"
+
RDEPEND="net-wireless/wireless-tools"
-S="${WORKDIR}/${MY_P}"
MODULE_NAMES="rt73(net:${S}/Module)"
+S=${WORKDIR}/${MY_P}
+
CONFIG_CHECK="NET_RADIO"
ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
-
MODULESD_RT73_ALIASES=('usbra? rt73')
pkg_setup() {
@@ -33,18 +33,20 @@ pkg_setup() {
src_unpack (){
unpack ${A}
- cd ${S}/Module
-# Portage expects to do make module, not make all
-# Only patch the makefile we are going to use
-# Makefile.4 Makefile for kernel 2.4 series
+ cd "${S}/Module"
+
+ # Portage expects to do make module, not make all
+ # Only patch the makefile we are going to use
+
+ # Makefile.4 - Makefile for kernel 2.4 series
if kernel_is 2 4 ; then
- epatch ${FILESDIR}/make4.patch
+ epatch "${FILESDIR}/make4.patch"
cp Makefile.4 Makefile
fi
-# Makefile.6 Makefile for kernel 2.6 series
+ # Makefile.6 - Makefile for kernel 2.6 series
if kernel_is 2 6 ; then
- epatch ${FILESDIR}/make6.patch
+ epatch "${FILESDIR}/make6.patch"
cp Makefile.6 Makefile
fi
if ! [ -f Makefile ]; then
@@ -53,8 +55,8 @@ src_unpack (){
die
fi
-# if you are really careful you can edit this patch to add your RT73 Device too
- epatch ${FILESDIR}/deviceID.patch
+ # You can edit patch to also add your RT73 device if you are careful.
+ epatch "${FILESDIR}/deviceID.patch"
}
@@ -66,7 +68,7 @@ src_compile() {
src_install() {
linux-mod_src_install
dodoc Module/README Module/iwpriv_usage.txt
-# The firmware Install
+ # The firmware install
insinto /etc/Wireless/RT73STA
doins Module/rt73.bin Module/rt73sta.dat
}