summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-01-27 14:37:15 +0000
committerJakub Moc <jakub@gentoo.org>2008-01-27 14:37:15 +0000
commit38eba6a874858bdbe9df63aaee0ad2de24dbab6e (patch)
tree77639647f48ed8b71ee34046a268112cf6b3fd15 /net-wireless/rt73/rt73-1.0.3.6.ebuild
parentRemove, this is in vanilla kernel (diff)
downloadsunrise-38eba6a874858bdbe9df63aaee0ad2de24dbab6e.tar.gz
sunrise-38eba6a874858bdbe9df63aaee0ad2de24dbab6e.tar.bz2
sunrise-38eba6a874858bdbe9df63aaee0ad2de24dbab6e.zip
Remove, outdated, plus a driver for this included in 2.6.24 vanilla kernel
svn path=/sunrise/; revision=5531
Diffstat (limited to 'net-wireless/rt73/rt73-1.0.3.6.ebuild')
-rw-r--r--net-wireless/rt73/rt73-1.0.3.6.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/net-wireless/rt73/rt73-1.0.3.6.ebuild b/net-wireless/rt73/rt73-1.0.3.6.ebuild
deleted file mode 100644
index 9f9cf092e..000000000
--- a/net-wireless/rt73/rt73-1.0.3.6.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit linux-mod
-
-DESCRIPTION="Driver for the RaLink RT73/2571 wireless chipsets"
-HOMEPAGE="http://www.ralink.com.tw/"
-SRC_URI="http://ralink.com.tw/data/RT73_Linux_STA_Drv${PV}.tar.gz"
-
-MY_P=RT73_Linux_STA_Drv${PV}
-
-# May work on other little endien arches, e.g amd64
-# Known broken on big endian arches
-LICENSE="GPL-2"
-KEYWORDS="~x86"
-IUSE="debug"
-
-S=${WORKDIR}/${MY_P}
-
-RDEPEND="net-wireless/wireless-tools"
-MODULE_NAMES="rt73(net:${S}/Module)"
-
-CONFIG_CHECK="WIRELESS_EXT"
-ERROR_WIRELESS_EXT="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
-MODULESD_RT73_ALIASES=('usbra? rt73')
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERNDIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
-
-}
-
-src_unpack (){
- unpack ${A}
- cd "${S}/Module"
-
- # Portage expects to do make module, not make all
- # Only patch the makefile we are going to use
-
- # Makefile.4 - Makefile for kernel 2.4 series
- if kernel_is 2 4 ; then
- epatch "${FILESDIR}/make4.patch"
- cp Makefile.4 Makefile
- fi
-
- # Makefile.6 - Makefile for kernel 2.6 series
- if kernel_is 2 6 ; then
- epatch "${FILESDIR}/make6.patch"
- cp Makefile.6 Makefile
- fi
- if ! [ -f Makefile ]; then
- ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.X"
- ewarn "this kernel version is not tested/supported"
- die
- fi
-
- # You can edit patch to also add your RT73 device if you are careful.
- epatch "${FILESDIR}/deviceID.patch"
-}
-
-src_compile() {
- use debug && export debug="y"
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
- dodoc Module/README Module/iwpriv_usage.txt
- # The firmware install
- insinto /etc/Wireless/RT73STA
- doins Module/rt73.bin Module/rt73sta.dat
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
-
- einfo
- einfo "Thanks to RaLink for releasing open drivers!"
- einfo
-}