summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-06-30 14:07:35 +0000
committerJakub Moc <jakub@gentoo.org>2007-06-30 14:07:35 +0000
commit893e443851f3807aa61effde89ea04e1723d03b7 (patch)
tree1ca6db58a71c16f11b9dbec00ca581e924a23fba /sci-biology/clover/clover-2006.07.17.ebuild
parentCosmetics (diff)
downloadsunrise-893e443851f3807aa61effde89ea04e1723d03b7.tar.gz
sunrise-893e443851f3807aa61effde89ea04e1723d03b7.tar.bz2
sunrise-893e443851f3807aa61effde89ea04e1723d03b7.zip
sci-biology/clover: einfo -> elog; cosmetics
svn path=/sunrise/; revision=4098
Diffstat (limited to 'sci-biology/clover/clover-2006.07.17.ebuild')
-rw-r--r--sci-biology/clover/clover-2006.07.17.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sci-biology/clover/clover-2006.07.17.ebuild b/sci-biology/clover/clover-2006.07.17.ebuild
index 4cf143b0f..d86b96e85 100644
--- a/sci-biology/clover/clover-2006.07.17.ebuild
+++ b/sci-biology/clover/clover-2006.07.17.ebuild
@@ -5,10 +5,11 @@
inherit versionator toolchain-funcs
MY_PV=$(replace_all_version_separators '-')
-
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="Cis-eLement OVERrepresentation: Detection of functional DNA motifs"
HOMEPAGE="http://zlab.bu.edu/clover/"
-SRC_URI="http://zlab.bu.edu/~mfrith/downloads/${PN}-${MY_PV}.tar.gz http://zlab.bu.edu/clover/jaspar2005core"
+SRC_URI="http://zlab.bu.edu/~mfrith/downloads/${MY_P}.tar.gz
+ http://zlab.bu.edu/clover/jaspar2005core"
LICENSE="as-is"
SLOT="0"
@@ -18,26 +19,25 @@ KEYWORDS="~x86"
DEPEND=""
RDEPEND=""
-S="${WORKDIR}/${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
src_unpack() {
- unpack ${PN}-${MY_PV}.tar.gz
+ unpack ${MY_P}.tar.gz
+ sed -i "s:g++:$(tc-getCXX):; s:-Wall -O3:${CFLAGS}:" Makefile || die "sed failed"
}
src_compile() {
- sed -i "s:g++:$(tc-getCXX):; s:-Wall -O3:${CFLAGS}:" Makefile || die "sed failed"
emake || die "emake failed"
}
src_install() {
dobin clover
- dodir "/usr/share/${PN}"
- insinto "/usr/share/${PN}"
- doins ${DISTDIR}/jaspar2005core || die
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/jaspar2005core || die "doins failed"
}
pkg_postinst() {
- einfo "The motif library jaspar2005core has been installed in"
- einfo " /usr/share/clover/jaspar2005core"
- einfo "You can pass this library to clover for motif search, or use your own library."
+ elog "The motif library jaspar2005core has been installed in"
+ elog " /usr/share/clover/jaspar2005core"
+ elog "You can pass this library to clover for motif search, or use your own library."
}