summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-06-19 15:56:21 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-06-19 15:56:21 +0000
commit02db3274a343f0c732e5238b0ab9b8991886d288 (patch)
tree9e805b83d5054e8cefbc22dfcc056ad151f99f75 /scripts
parentscript/ovl-ebuild.sh: QA fix (diff)
downloadsunrise-02db3274a343f0c732e5238b0ab9b8991886d288.tar.gz
sunrise-02db3274a343f0c732e5238b0ab9b8991886d288.tar.bz2
sunrise-02db3274a343f0c732e5238b0ab9b8991886d288.zip
script/ovl-ebuild.sh: fix
svn path=/sunrise/; revision=139
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/ovl-ebuilds.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/ovl-ebuilds.sh b/scripts/ovl-ebuilds.sh
index 8766e268c..6b66ecad1 100755
--- a/scripts/ovl-ebuilds.sh
+++ b/scripts/ovl-ebuilds.sh
@@ -3,6 +3,7 @@
# Copyright 2006 Piotr Jaroszyński <peper@aster.pl>
# Distributed under the terms of the GNU General Public License v2
+source /etc/make.globals
source /etc/make.conf
echo "This will take a while depending on no. of installed packages."
@@ -19,7 +20,7 @@ while read EBUILD_PATH; do
fi
echo -e "\t${CATEGORY}/${PKG}"
-done < <(bzcat /var/db/pkg/*/*/environment.bz2 | grep EBUILD=/ | grep -v $PORTDIR | sort \
+done < <(bzcat /var/db/pkg/*/*/environment.bz2 | grep "EBUILD=/" | grep -v ${PORTDIR} | sort \
| sed -e 's/EBUILD=//' -e 's/.ebuild//')
unset OVERLAY LASTOVERLAY CATEGORY PKG