summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-12 11:14:56 +0800
committerPatrick Lauer <patrick@gentoo.org>2013-03-12 11:14:56 +0800
commit8ef76a1d901f8c8614ac0e2745f4d85beb7db919 (patch)
tree5f05ea45c3a3a70a39d48ac98f57ac02d7f0ca88 /sys-apps/pcp/pcp-3.7.0.ebuild
parent[sys-cluster/clusterit] Adding ~amd64 keyword (diff)
downloadsunrise-8ef76a1d901f8c8614ac0e2745f4d85beb7db919.tar.gz
sunrise-8ef76a1d901f8c8614ac0e2745f4d85beb7db919.tar.bz2
sunrise-8ef76a1d901f8c8614ac0e2745f4d85beb7db919.zip
[sys-apps/pcp] Adding ~amd64 keyword, bump, EAPI bump
Diffstat (limited to 'sys-apps/pcp/pcp-3.7.0.ebuild')
-rw-r--r--sys-apps/pcp/pcp-3.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/pcp/pcp-3.7.0.ebuild b/sys-apps/pcp/pcp-3.7.0.ebuild
new file mode 100644
index 000000000..1176f88d4
--- /dev/null
+++ b/sys-apps/pcp/pcp-3.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit flag-o-matic
+
+DESCRIPTION="A framework and services to support system-level performance monitoring and performance management"
+HOMEPAGE="http://oss.sgi.com/projects/pcp/"
+SRC_URI="ftp://oss.sgi.com/projects/${PN}/download/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+ econf || die "econf failed"
+}
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ DIST_ROOT="${D}" emake install || die "emake install failed"
+ dodoc CHANGELOG README
+}