summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-07-06 22:24:59 +0000
committerMichał Górny <mgorny@gentoo.org>2010-07-06 22:24:59 +0000
commit0b451fb758195200341f59ceecec1b06f3e28a44 (patch)
tree011b04d191ceab352e6424e968499c745b3d6843 /sys-apps
parentx11-misc/gxneur: Cleanup, install the icon. (diff)
downloadsunrise-0b451fb758195200341f59ceecec1b06f3e28a44.tar.gz
sunrise-0b451fb758195200341f59ceecec1b06f3e28a44.tar.bz2
sunrise-0b451fb758195200341f59ceecec1b06f3e28a44.zip
sys-apps/fspy: Use Google Code SRC_URI as the original does not work anymore. Fix src_compile() to respect CC & LDFLAGS.
svn path=/sunrise/; revision=10937
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fspy/ChangeLog7
-rw-r--r--sys-apps/fspy/Manifest4
-rw-r--r--sys-apps/fspy/fspy-0.1.1.ebuild11
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-apps/fspy/ChangeLog b/sys-apps/fspy/ChangeLog
index 14ad7f434..84541fa1b 100644
--- a/sys-apps/fspy/ChangeLog
+++ b/sys-apps/fspy/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-apps/fspy
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jul 2010; Michał Górny (sedzimir) <mgorny.3ehbo@mailnull.com>
+ fspy-0.1.1.ebuild:
+ Use Google Code SRC_URI as the original does not work anymore. Fix
+ src_compile() to respect CC & LDFLAGS.
+
05 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> fspy-0.1.1.ebuild:
Fix dodoc command.
diff --git a/sys-apps/fspy/Manifest b/sys-apps/fspy/Manifest
index 045dc6b37..056a50295 100644
--- a/sys-apps/fspy/Manifest
+++ b/sys-apps/fspy/Manifest
@@ -1,4 +1,4 @@
DIST fspy-0.1.1.tar.bz2 49245 RMD160 371ee45bb38e681bda7ebe911fa58f9c57f2ca93 SHA1 f11e3e9312d0b0192ede4b92e6d5a4b62ad39a83 SHA256 b4289d601e7d7f6b81445272eb75eddc73f38cf331107327085abc393b23b73c
-EBUILD fspy-0.1.1.ebuild 513 RMD160 4555a8a8e122bc980f8db0ca3642428c2c030bf4 SHA1 1bf48f7e5532275aa01fa884f73f3a6af73bf028 SHA256 7150d90a4b7377535cc079ac4f8a782269e877ae005cc85df45f2c206e0b5b70
-MISC ChangeLog 392 RMD160 0c52f5959823e11e227ce9ab76493b615c697428 SHA1 5db15a4b8cc5b8bc10c416bc4d5378acc4c2514b SHA256 a7b751eec1b8332f7c1495f042700e4ae29eff0cfc3a57b3a698c128e5c2daa7
+EBUILD fspy-0.1.1.ebuild 625 RMD160 e6cd5940c8bbad3a37ddb5fa4ae9cb1b07ddf750 SHA1 5a3e488074531bf948d025e21f13ed7cb2f18fe5 SHA256 32f002e89eb685ea0fe1467ec44e58abb0626fb11f5535c5ff32ae2c2a7a4c4d
+MISC ChangeLog 593 RMD160 4897358804a2f5f7d088d5f10d0535f3c442ea09 SHA1 64c2822ee9ae541a764312e10c5aa9b1986730e2 SHA256 2e402ecb4d27362fd1e2f1370ef7888f00b8bbd0c7a07dacdf95b51a00454c74
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/sys-apps/fspy/fspy-0.1.1.ebuild b/sys-apps/fspy/fspy-0.1.1.ebuild
index 826a0c1b7..7903ed594 100644
--- a/sys-apps/fspy/fspy-0.1.1.ebuild
+++ b/sys-apps/fspy/fspy-0.1.1.ebuild
@@ -2,9 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit toolchain-funcs
+
DESCRIPTION="Easy to use filesystem activity monitoring"
HOMEPAGE="http://mytty.org/fspy/"
-SRC_URI="http://mytty.org/fspy/${P}.tar.bz2"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -12,8 +14,11 @@ KEYWORDS="~x86"
IUSE=""
src_compile() {
- emake clean
- emake INSTBINDIR=$DESTDIR || die "emake failed"
+ local cc=$(tc-getCC)
+
+ emake clean || die
+ # LDFLAGS var is passed when compiling too...
+ emake CC="${cc}" LD="${cc} ${LDFLAGS}" || die
}
src_install() {