summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2009-05-11 12:03:49 +0000
committerJustin Lecher <jlec@gentoo.org>2009-05-11 12:03:49 +0000
commitca0507be501656846e14ca3f894f7cd45ee2df0a (patch)
tree4bab7bdbb51819d56f8c6bd734d22f126d1ae0c4 /sys-fs/tdu/tdu-2008.05.07.ebuild
parentsys-fs/ext3grep: sys-fs/ext3grep use base eclass (diff)
downloadsunrise-ca0507be501656846e14ca3f894f7cd45ee2df0a.tar.gz
sunrise-ca0507be501656846e14ca3f894f7cd45ee2df0a.tar.bz2
sunrise-ca0507be501656846e14ca3f894f7cd45ee2df0a.zip
sys-fs/tdu: sys-fs/tdu added
svn path=/sunrise/; revision=8524
Diffstat (limited to 'sys-fs/tdu/tdu-2008.05.07.ebuild')
-rw-r--r--sys-fs/tdu/tdu-2008.05.07.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/tdu/tdu-2008.05.07.ebuild b/sys-fs/tdu/tdu-2008.05.07.ebuild
new file mode 100644
index 000000000..0c21de7a8
--- /dev/null
+++ b/sys-fs/tdu/tdu-2008.05.07.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator base toolchain-funcs
+
+MY_P="${PN}-$(replace_all_version_separators - ${PV})"
+
+DESCRIPTION="terminal program that displays disk space utilization in an interactive full-screen folding outline"
+HOMEPAGE="http://webonastick.com/tdu/"
+SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ dev-libs/glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+S="${WORKDIR}"/${PN}
+
+PATCHES=( "${FILESDIR}"/${PV}-DESTDIR.patch )
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) || \
+ die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ dodoc README TODO || die "nothing to read"
+}