summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-02-26 18:17:46 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-02-26 18:17:46 +0000
commit547b1e8c9ec4b988e985fbf7b778413941a00c33 (patch)
treefbd688714c3d7c60648a2711f390148dd4cd1750 /sys-power/acpi_call/acpi_call-9999.ebuild
parentmedia-tv/kmttg: Version bump for kmttg (diff)
downloadsunrise-547b1e8c9ec4b988e985fbf7b778413941a00c33.tar.gz
sunrise-547b1e8c9ec4b988e985fbf7b778413941a00c33.tar.bz2
sunrise-547b1e8c9ec4b988e985fbf7b778413941a00c33.zip
sys-power/acpi_call: New Ebuild for bug 356605
svn path=/sunrise/; revision=11795
Diffstat (limited to 'sys-power/acpi_call/acpi_call-9999.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
new file mode 100644
index 000000000..b0c465ab6
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+
+inherit git linux-info linux-mod
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="clean default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}