summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2009-08-16 10:55:56 +0000
committerJustin Lecher <jlec@gentoo.org>2009-08-16 10:55:56 +0000
commit66d180cead59f84ac6cdadc7bdac868fcf69d475 (patch)
tree240d5ada3e4464842041f609f0dceb884ad1d011 /x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
parentgames-rpg/planeshift-bin: Add ~amd64 keyword (diff)
downloadsunrise-66d180cead59f84ac6cdadc7bdac868fcf69d475.tar.gz
sunrise-66d180cead59f84ac6cdadc7bdac868fcf69d475.tar.bz2
sunrise-66d180cead59f84ac6cdadc7bdac868fcf69d475.zip
x11-misc/xorg-edit: Make it build in parallel
svn path=/sunrise/; revision=9025
Diffstat (limited to 'x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch')
-rw-r--r--x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch62
1 files changed, 39 insertions, 23 deletions
diff --git a/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch b/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
index a8d1fa908..958fd32d3 100644
--- a/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
+++ b/x11-misc/xorg-edit/files/xorg-edit-08.08.06-makefile.patch
@@ -1,21 +1,6 @@
---- libxorgedit/Makefile 2008-08-05 18:46:23.000000000 +0200
-+++ libxorgedit/Makefile.new 2009-08-15 17:52:26.000000000 +0200
-@@ -6,10 +6,10 @@
- OUTPUT = ../libxorgedit.a
-
- # compiler
--CXX = g++
-+CXX ?= g++
-
- # C++ compiler flags (-g -O2 -Wall)
--CXXFLAGS = -Wall -Wextra -O3
-+#CXXFLAGS = -Wall -Wextra -O3
-
- # implementation
-
--- xorgedit/Makefile 2008-08-06 20:29:54.000000000 +0200
-+++ xorgedit/Makefile.new 2009-08-15 20:11:11.000000000 +0200
-@@ -18,23 +18,23 @@
++++ xorgedit/Makefile.new 2009-08-16 12:23:56.000000000 +0200
+@@ -18,26 +18,26 @@
INCLUDES = -I../
# C++ compiler flags (-g -O2 -Wall)
@@ -27,12 +12,11 @@
+CXX ?= `wx-config --cxx`
# library paths
--LIBS = -L../ -lm -lxorgedit
-+LIBS = -L../ -lm -lxorgedit `wx-config --libs`
+ LIBS = -L../ -lm -lxorgedit
# compile flags
-LDFLAGS = `wx-config --libs`
-+#LDFLAGS = `wx-config --libs`
++WXLIBS = `wx-config --libs`
# implementation
@@ -40,7 +24,39 @@
$(OUTPUT): $(OBJECTS)
- $(CXX) -o $(OUTPUT) $(OBJECTS) $(LIBS) $(LDFLAGS)
-+ $(CXX) $(LDFLAGS) -o $(OUTPUT) $(OBJECTS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(OUTPUT) $(OBJECTS) $(LIBS) $(WXLIBS)
+
+-$(OBJECTS): $(SOURCES)
+- $(CXX) $(INCLUDES) -c $(SOURCES) $(CXXFLAGS)
++%.o: %.c
++ $(CXX) $(INCLUDES) -c $@ $(CXXFLAGS) -o obj/$<
+
+ clean:
+ rm -f $(OBJECTS) $(OUTPUT)
+--- libxorgedit/Makefile 2008-08-05 18:46:23.000000000 +0200
++++ libxorgedit/Makefile.new 2009-08-16 12:21:32.000000000 +0200
+@@ -6,10 +6,10 @@
+ OUTPUT = ../libxorgedit.a
+
+ # compiler
+-CXX = g++
++CXX ?= g++
+
+ # C++ compiler flags (-g -O2 -Wall)
+-CXXFLAGS = -Wall -Wextra -O3
++#CXXFLAGS = -Wall -Wextra -O3
+
+ # implementation
+
+--- Makefile 2008-08-06 20:29:24.000000000 +0200
++++ Makefile.new 2009-08-16 12:53:07.000000000 +0200
+@@ -8,7 +8,8 @@
+
+ # implementation
+ all:
+- cd libxorgedit && make && cd ../xorgedit && make && cd ..
++ +make -C libxorgedit
++ +make -C xorgedit
- $(OBJECTS): $(SOURCES)
- $(CXX) $(INCLUDES) -c $(SOURCES) $(CXXFLAGS)
+ install:
+ cd libxorgedit && make && cd ../xorgedit && make install && cd ..