summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <sasuomin@uusikaupunki.fi>2006-06-07 22:26:38 +0000
committerSamuli Suominen <sasuomin@uusikaupunki.fi>2006-06-07 22:26:38 +0000
commit7c3999235428a0f1f0b4f0c3b1ee044610c58c68 (patch)
treedb12f4839b67e061af49074e3bec101a0c1f1c36 /x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild
downloadsunrise-7c3999235428a0f1f0b4f0c3b1ee044610c58c68.tar.gz
sunrise-7c3999235428a0f1f0b4f0c3b1ee044610c58c68.tar.bz2
sunrise-7c3999235428a0f1f0b4f0c3b1ee044610c58c68.zip
ebuild, fixes #69
svn path=/; revision=1
Diffstat (limited to 'x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild')
-rw-r--r--x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild b/x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild
new file mode 100644
index 000000000..f1f351bcd
--- /dev/null
+++ b/x11-plugins/cairo-clock/cairo-clock-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Clock for desktop with ARGB visuals."
+HOMEPAGE="http://macslow.thepimp.net/?page_id=23"
+SRC_URI="http://macslow.thepimp.net/projects/cairo-clock/$P.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+DEPEND=">=x11-libs/cairo-1.0.2
+ >=x11-libs/gtk+-2.8.8
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/librsvg-2.14"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed."
+ dodoc README NEWS AUTHORS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Note, that you need running composite manager for visuals."
+ epause 5
+ echo
+}