summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJürgen Geuter (tante) <tante@emptiness.de>2007-03-06 20:52:17 +0000
committerJürgen Geuter (tante) <tante@emptiness.de>2007-03-06 20:52:17 +0000
commitac28e645b0608327fd3de76f510508c3ff566edd (patch)
tree2d287438857ccae850cdc1d82e8004169fb5f1a3 /x11-plugins
parentnet-libs/raknet: New ebuild for bug 164721 thanks to Renaud Chaput (diff)
downloadsunrise-ac28e645b0608327fd3de76f510508c3ff566edd.tar.gz
sunrise-ac28e645b0608327fd3de76f510508c3ff566edd.tar.bz2
sunrise-ac28e645b0608327fd3de76f510508c3ff566edd.zip
x11-plugins/gaim-plugin_pack: New Ebuild for bug 134430
svn path=/sunrise/; revision=3152
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-plugin_pack/ChangeLog7
-rwxr-xr-xx11-plugins/gaim-plugin_pack/gaim-plugin_pack-1.0_beta6.ebuild70
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-plugins/gaim-plugin_pack/ChangeLog b/x11-plugins/gaim-plugin_pack/ChangeLog
new file mode 100644
index 000000000..d10193a55
--- /dev/null
+++ b/x11-plugins/gaim-plugin_pack/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for x11-plugins/gaim-plugin_pack
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 06 Mar 2007; Jürgen Geuter (tante) <tante@emptiness.de> ChangeLog:
+ New Ebuild for bug 134430
+
diff --git a/x11-plugins/gaim-plugin_pack/gaim-plugin_pack-1.0_beta6.ebuild b/x11-plugins/gaim-plugin_pack/gaim-plugin_pack-1.0_beta6.ebuild
new file mode 100755
index 000000000..a0584f94f
--- /dev/null
+++ b/x11-plugins/gaim-plugin_pack/gaim-plugin_pack-1.0_beta6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PV=${PV/_beta/beta}
+MY_P="$PN-${MY_PV}"
+
+DESCRIPTION="A package with many different plugins for gaim"
+HOMEPAGE="http://gaim.guifications.org"
+SRC_URI="http://downloads.guifications.org/gaim-plugins/Plugin%20Pack/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+FLAGS="autorejoin awaynotify bit blistops dice difftopic eight_ball flip
+ gRIM groupmsg irssi lastseen listhandler mystatusbox nicksaid oldlogger
+ plonkers sepandtab showoffline simfix slashexec sslinfo talkfilters
+ xchat-chats"
+IUSE="${FLAGS} bashorg debug"
+
+DEPEND="=net-im/gaim-2.0.0_beta6
+ talkfilters? ( app-text/talkfilters )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+ einfo "The plugins that are to be built are configured via use flags."
+ einfo "If none of the optional use flags is set _ALL_ plugins are built,"
+ einfo "so adjusting /etc/portage/package.use might be a good idea before merging."
+ # XMMS Remote is disabled due to XMMS being masked
+ #
+ # Disabled due to non-working status:
+ # Gaim Schedule (http://gaim.guifications.org/trac/wiki/GaimSchedule)
+ # buddytime
+ # chronic
+ # Stocker (http://gaim.guifications.org/trac/wiki/stocker)
+ #
+ # Disabled due to being included in current gaim release:
+ # Auto Accept
+ # Auto Reply
+ # Buddy Note
+ # convcolors
+ # Marker Line
+ # New Line
+ # Offline Message
+
+ myconf="--with-plugins="
+
+ # bashorg has to add "bash" to the configure
+ if use bashorg ; then
+ myconf="${myconf}bash,"
+ fi
+
+ for flag in $FLAGS ; do
+ if use $flag ; then
+ myconf="${myconf}${flag},"
+ fi
+ done
+
+ econf ${myconf} $(use_enable debug)|| die "Configuration failed with the configuration $myconf"
+ emake -j1 || die "Make failed"
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO VERSION
+}