summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/playonlinux/ChangeLog8
-rw-r--r--games-util/playonlinux/Manifest4
-rw-r--r--games-util/playonlinux/metadata.xml5
-rw-r--r--games-util/playonlinux/playonlinux-3.0.1.ebuild49
4 files changed, 66 insertions, 0 deletions
diff --git a/games-util/playonlinux/ChangeLog b/games-util/playonlinux/ChangeLog
new file mode 100644
index 000000000..6e3beb911
--- /dev/null
+++ b/games-util/playonlinux/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-util/playonlinux
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 01 Jun 2008; Mounir Lamouri (Volkmar) <mounir.lamouri@gmail.com>
+ +playonlinux-3.0.1.ebuild, +metadata.xml:
+ New ebuild for bug 213287.
+
diff --git a/games-util/playonlinux/Manifest b/games-util/playonlinux/Manifest
new file mode 100644
index 000000000..8187c2a20
--- /dev/null
+++ b/games-util/playonlinux/Manifest
@@ -0,0 +1,4 @@
+DIST PlayOnLinux_3.0.1.tar.gz 1001421 RMD160 751074b5f0702c414f0d73d5c0a09719b8389dcc SHA1 5dd516fa3e42907df5e7135396029a568c3ca417 SHA256 65d35abb755b160b17508e76ec25244729a950fd65a96801f9bdf26ca923bc7b
+EBUILD playonlinux-3.0.1.ebuild 1025 RMD160 a873d2d31223442c2f8db54c3c70ca46b0345cdc SHA1 2deddcf9b736a54aabc3ce6ac9f55746a0ce52b7 SHA256 f83201fb545c1f231d89e8190bbd1d00d011d40224c4c7d5cd14e650bbd5a761
+MISC ChangeLog 264 RMD160 0687e62450d9ed50dccc6971397e19494b371295 SHA1 c9e0076a7096b529d6d968429f76f946214cf84a SHA256 3bf89272aa9faf405757af4d6ca298a0399e6d350cf7fcbe6f074a44cc5a0e48
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-util/playonlinux/metadata.xml b/games-util/playonlinux/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-util/playonlinux/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/games-util/playonlinux/playonlinux-3.0.1.ebuild b/games-util/playonlinux/playonlinux-3.0.1.ebuild
new file mode 100644
index 000000000..a23bd6aeb
--- /dev/null
+++ b/games-util/playonlinux/playonlinux-3.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit games
+
+DESCRIPTION="PlayOnLinux is a piece of sofware which allow you to install and use easily numerous games and softwares designed to run with Windows(tm)."
+HOMEPAGE="http://www.playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/PlayOnLinux/${PV}/PlayOnLinux_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ x11-libs/wxGTK
+ x11-libs/gtk+
+ www-client/lynx
+ app-arch/unzip
+ app-arch/cabextract
+ sys-devel/binutils
+ x11-terms/xterm
+ app-emulation/wine
+ media-gfx/imagemagick
+ app-arch/lzma-utils"
+RDEPEND="${DEPEND}
+ dev-python/wxpython"
+
+S="${WORKDIR}/playonlinux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_install() {
+ cd "${S}"
+ ./playonlinux || die "install failed"
+ einfo "Fix for License miss spelling"
+ addpredict "${S}"
+ addread "${S}"
+ mv LICENCE LICENSE
+
+ dodoc CHANGELOG LICENSE || die "doc failed"
+}
+