summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/Manifest5
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-0.1.1.20080901.ebuild39
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-9999.ebuild51
-rw-r--r--app-i18n/ibus-anthy/metadata.xml5
5 files changed, 108 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
new file mode 100644
index 000000000..189121348
--- /dev/null
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-i18n/ibus-anthy
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Sep 2008; Hong Hao <oahong@gmail.com>
+ +ibus-anthy-0.1.1.20080901.ebuild, +ibus-anthy-9999.ebuild, +metadata.xml:
+ Ebuild for bug #236368
+
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
new file mode 100644
index 000000000..10331292e
--- /dev/null
+++ b/app-i18n/ibus-anthy/Manifest
@@ -0,0 +1,5 @@
+DIST ibus-anthy-0.1.1.20080901.tar.gz 386225 RMD160 b59c6f6bc89f2d6a41bcb4a401e5c7455e81aa4e SHA1 d83cbfab4367b9130319ce6498b71c0cfb4eccae SHA256 286d82fbabe54698899b7a62f325f7da927cd43f1c722bf2d655511710042d71
+EBUILD ibus-anthy-0.1.1.20080901.ebuild 966 RMD160 526a5f10f16f02f09ac1d1a6d980ad315a3729e5 SHA1 bf86af21a63ddbb6ac7bbcf02c2ea59841e2744c SHA256 ce0208e07fcc68b257f61d759bc7f4fd910205864bdcc4f68d1bcccf66f30b43
+EBUILD ibus-anthy-9999.ebuild 1126 RMD160 7b245691c66da0ba8ca9112f1d446004135c5e26 SHA1 422cbc8e1e4f0007ef539f48095e18fd2291a9a5 SHA256 bcb778ae79e7f4f9837bf6db5a30b92f2d698e5101391b0eabc521866790d561
+MISC ChangeLog 266 RMD160 d547d4cd9847df6fa4cc1b3444f337fe9e36d84d SHA1 9922850057276dc852cdea0026b97b1f24ec7f1d SHA256 d5d5aa933efdb605c7344f8a58b90ae939f5064fbaa31fe55063403b69df30a6
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-i18n/ibus-anthy/ibus-anthy-0.1.1.20080901.ebuild b/app-i18n/ibus-anthy/ibus-anthy-0.1.1.20080901.ebuild
new file mode 100644
index 000000000..2cc03c361
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-0.1.1.20080901.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://ibus.googlecode.com"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="app-i18n/anthy
+ >=dev-lang/python-2.5
+ dev-lang/swig
+ nls? ( sys-devel/gettext )"
+RDEPEND="app-i18n/ibus
+ app-i18n/anthy
+ >=dev-lang/python-2.5"
+
+src_compile() {
+ econf $(use_enable nls) \
+ --enable-maintainer-mode \
+ --disable-option-checking \
+ --disable-rpath
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog "You should run ibus-setup and enable IM Engines you want to use."
+}
diff --git a/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild b/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild
new file mode 100644
index 000000000..8325b5fa2
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+EGIT_REPO_URI="git://github.com/phuang/ibus-anthy.git"
+
+inherit autotools git
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://ibus.googlecode.com"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls"
+
+# autopoint needs cvs. Bug #152872
+DEPEND="app-i18n/anthy
+ >=dev-lang/python-2.5
+ dev-lang/swig
+ sys-devel/gettext
+ dev-util/cvs"
+RDEPEND="app-i18n/ibus
+ app-i18n/anthy
+ >=dev-lang/python-2.5"
+
+src_unpack() {
+ git_src_unpack
+ autopoint || die "failed to run autopoint"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ --enable-maintainer-mode \
+ --disable-option-checking \
+ --disable-rpath
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog "You should run ibus-setup and enable IM Engines you want to use."
+}
diff --git a/app-i18n/ibus-anthy/metadata.xml b/app-i18n/ibus-anthy/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-i18n/ibus-anthy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>