summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/plr/ChangeLog8
-rw-r--r--dev-db/plr/Manifest6
-rw-r--r--dev-db/plr/metadata.xml5
-rw-r--r--dev-db/plr/plr-8.2.0.10.ebuild69
-rw-r--r--dev-db/plr/plr-8.3.0.8.ebuild69
5 files changed, 157 insertions, 0 deletions
diff --git a/dev-db/plr/ChangeLog b/dev-db/plr/ChangeLog
new file mode 100644
index 000000000..b987fd9fb
--- /dev/null
+++ b/dev-db/plr/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-db/plr
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Jun 2009; Ian Stakenvicius (_AxS_) <ian@aerobiology.ca>
+ +plr-8.2.0.10.ebuild, +plr-8.3.0.8.ebuild, +metadata.xml:
+ Initial commit; thanks to idl0r for help with ebuild form
+
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
new file mode 100644
index 000000000..37d52acf6
--- /dev/null
+++ b/dev-db/plr/Manifest
@@ -0,0 +1,6 @@
+DIST plr-8.2.0.10.tar.gz 232681 RMD160 37ba2448cfdacb9c75565670a0b47f30b8a018a0 SHA1 35d76ed1fa3564dc146afb197c846ea81370782c SHA256 899a4c3ba5244006fb47a7e1e891d408211a981020488554a45e18ec3bb60b07
+DIST plr-8.3.0.8.tar.gz 232880 RMD160 fc33bcdd94ca524215be5c729b6ff0697d678579 SHA1 36b94678b84bd408c557779b839a25c490405eec SHA256 493078d1d9df2606a8ebdfa1fe643cb3d24e727fa2dd4ad06beada871db4056c
+EBUILD plr-8.2.0.10.ebuild 1826 RMD160 34fd92c74d3fbabb6e8721e27e8a5c1ad2098ff0 SHA1 2d97dbfa4e6d949751ea1d29a7099804cd8d613d SHA256 dd4a4d1468d0514e00412c803436ba805e54dbc137d0acd9b72ed9485e6bbae6
+EBUILD plr-8.3.0.8.ebuild 1826 RMD160 4f1baef0f88c1801081bf729934c8798ae4f2d6b SHA1 1f6ee3b96c0c2216cb23b12b7440c8eae8846353 SHA256 74b6d828ebedd09af40191beed7d54ff35bb3c4dd39190dac060b89f8a1e781a
+MISC ChangeLog 293 RMD160 6f6ebe3fd079017f64ee0bb7bb86a907885f0609 SHA1 39e125408a3d791b3564c91ff152b10019d9ae3a SHA256 d4e9609eed421322430f0ae3ea91367351d316c94a3257322fd99bba26454709
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-db/plr/metadata.xml b/dev-db/plr/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-db/plr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-db/plr/plr-8.2.0.10.ebuild b/dev-db/plr/plr-8.2.0.10.ebuild
new file mode 100644
index 000000000..9266e4a5c
--- /dev/null
+++ b/dev-db/plr/plr-8.2.0.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit multilib
+
+DESCRIPTION="R language addon for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="http://www.joeconway.com/plr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="8.2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/R
+ =virtual/postgresql-server-${SLOT}*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/contrib/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ # the build system wants 'contrib' to be part of the path
+ mkdir "${WORKDIR}/contrib"
+ mv "${WORKDIR}/${PN}" "${S}"
+}
+
+src_compile() {
+ if has_version "dev-db/postgresql-server:${SLOT}" ; then
+ export PG_CONFIG="/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config"
+ fi
+ USE_PGXS=1 emake -j1 || die "emake failed"
+}
+
+src_install() {
+ USE_PGXS=1 emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ local sharepath
+ if has_version "dev-db/postgresql-server:${SLOT}" ; then
+ sharepath="/usr/share/postgresql-${SLOT}/contrib"
+ else
+ sharepath="/usr/share/postgresql/contrib"
+ fi
+ einfo
+ einfo "To install PL/R to your database issue"
+ einfo
+ einfo "\t psql -d mydatabase -U pg_username < ${sharepath}/plr.sql"
+ einfo
+ einfo "You may have to login as database administrator."
+ einfo
+ einfo "You have to define PL/R as TRUSTED language to allow non-administrators"
+ einfo "to use it. Change the CREATE LANGUAGE statement in the plr.sql file"
+ einfo "into"
+ einfo
+ einfo "\t CREATE TRUSTED LANGUAGE plr HANDLER plr_call_handler;"
+ einfo
+ einfo "update the database as shown above and allow a specific user to"
+ einfo "use PL/R by"
+ einfo
+ einfo "\t GRANT USAGE ON LANGUAGE plr TO pg_username;"
+ einfo
+ einfo "For further information on PL/R have a look at"
+ einfo
+ einfo "\t http://www.joeconway.com/plr/"
+ einfo
+}
diff --git a/dev-db/plr/plr-8.3.0.8.ebuild b/dev-db/plr/plr-8.3.0.8.ebuild
new file mode 100644
index 000000000..e45f9728f
--- /dev/null
+++ b/dev-db/plr/plr-8.3.0.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit multilib
+
+DESCRIPTION="R language addon for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="http://www.joeconway.com/plr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="8.3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/R
+ =virtual/postgresql-server-${SLOT}*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/contrib/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ # the build system wants 'contrib' to be part of the path
+ mkdir "${WORKDIR}/contrib"
+ mv "${WORKDIR}/${PN}" "${S}"
+}
+
+src_compile() {
+ if has_version "dev-db/postgresql-server:${SLOT}" ; then
+ export PG_CONFIG="/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config"
+ fi
+ USE_PGXS=1 emake -j1 || die "emake failed"
+}
+
+src_install() {
+ USE_PGXS=1 emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ local sharepath
+ if has_version "dev-db/postgresql-server:${SLOT}" ; then
+ sharepath="/usr/share/postgresql-${SLOT}/contrib"
+ else
+ sharepath="/usr/share/postgresql/contrib"
+ fi
+ einfo
+ einfo "To install PL/R to your database issue"
+ einfo
+ einfo "\t psql -d mydatabase -U pg_username < ${sharepath}/plr.sql"
+ einfo
+ einfo "You may have to login as database administrator."
+ einfo
+ einfo "You have to define PL/R as TRUSTED language to allow non-administrators"
+ einfo "to use it. Change the CREATE LANGUAGE statement in the plr.sql file"
+ einfo "into"
+ einfo
+ einfo "\t CREATE TRUSTED LANGUAGE plr HANDLER plr_call_handler;"
+ einfo
+ einfo "update the database as shown above and allow a specific user to"
+ einfo "use PL/R by"
+ einfo
+ einfo "\t GRANT USAGE ON LANGUAGE plr TO pg_username;"
+ einfo
+ einfo "For further information on PL/R have a look at"
+ einfo
+ einfo "\t http://www.joeconway.com/plr/"
+ einfo
+}